Skip to:
Content

#4632 closed defect (bug) (invalid)

my-sites.php Create site slug

Reported by: gmax21 Owned by:
Milestone: 1.7 Priority: normal
Severity: minor Version:
Component: Core Keywords: reporter-feedback
Cc:

Description

Forgive me is this is reported, I couldn't find it and I didn't see it in the source.

/buddypress/bp-blogs/bp-blogs-filters.php

Returns the old slug /blogs/create if the page was custom it didn't return the new custom page.

Proposed change from:

function bp_blogs_creation_location( $url ) {
     return apply_filters( 'bp_blogs_creation_location', trailingslashit( bp_get_root_domain() . '/' . bp_get_blogs_slug() . '/create', $url ) );
}
add_filter( 'wp_signup_location', 'bp_blogs_creation_location' );

To:

function bp_blogs_creation_location( $url ) {
     return apply_filters( 'bp_blogs_creation_location', trailingslashit( bp_get_root_domain() . '/' . bp_get_blogs_root_slug() . '/create', $url ) );
}
add_filter( 'wp_signup_location', 'bp_blogs_creation_location' );

Thanks.

Change History (8)

comment:1 DJPaul18 months ago

  • Milestone changed from Awaiting Review to 1.7

comment:2 djpaul18 months ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6477]) Use the correct root slug when filtering the site registration link on wp-admin/my-sites.php.

This fixes an invalid link when the Sites directory page slug is different from "blogs".

Fixes #4632, props gmax21

comment:3 j.conti12 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I think this is broken again.

comment:4 boonebgorges12 months ago

  • Keywords reporter-feedback added; has-patch removed

I think this is broken again.

Please provide details to reproduce, including versions of relevant software.

comment:5 j.conti12 months ago

Ok,

This is a WordPress Multisite 3.5.1 + BuddyPress 1.7 in the main site

With a custom Blogs directory URL (/empresas-afiliadas/) the "Create site" is pointing to /blogs/create/ instead of /empresas-afiliadas/create/ so I'm getting a 404

comment:6 boonebgorges12 months ago

Thanks. I'm leaving this ticket in Awaiting Review until someone has been able to replicate.

Was there a version where it worked? (You said "broken again".)

comment:7 j.conti12 months ago

I don't know, I said again because I reopened this tiket.

comment:8 j.conti12 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

I close this ticket, it is a theme bug.

Note: See TracTickets for help on using tickets.