Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4374 closed defect (bug) (duplicate)

1.6 RC.1 - profile date fields in members-loop

Reported by: shanebp Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.6
Component: Extended Profile Keywords:
Cc: sam3dus@…

Description

If you create a profile field and the Type is Date Selector...

bp_the_profile_field_value(), used in bp-default -> profile-loop, shows and formats the value

bp_member_profile_data( 'field=Date' ), used in bp-default -> members-loop, does Not show the value

Possible explanation:
"BuddyPress stores the output of the datebox as a string like "2012-07-19 00:00:00". bp_get_member_profile_data() retrieves that from the database and then passes it to xprofile_format_profile_field(), which passes it to bp_format_time(), which returns false because the value fails the is_numeric() check."

Per:
http://stackoverflow.com/questions/11563198/buddypress-custom-profile-date-field-not-showing-in-loop

I tested this in members-loop and you can see the result here:
http://shanebp.bearcentral.com/members/

Change History (4)

#1 @shanebp
10 years ago

  • Cc sam3dus@… added

#2 @luccame
10 years ago

  • Component changed from Members to XProfile
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version set to 1.6-beta

duplicate of #4365

#3 @DJPaul
10 years ago

  • Milestone Awaiting Review deleted

#4 @johnjamesjacoby
7 years ago

  • Version changed from 1.6-beta to 1.6
Note: See TracTickets for help on using tickets.