Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4355 closed defect (bug) (fixed)

Delete Account as admin

Reported by: shanebp's profile shanebp Owned by:
Milestone: 1.6 Priority: normal
Severity: normal Version: 1.6
Component: Core Keywords:
Cc:

Description

On my test install, on the top toolbar,
Edit Member -> Delete Account
tries to go here
.com/members/zxvc/settings/delete-account/
but results in Page not Found"

It works if this is checked, on page=bp-settings
"Allow registered members to delete their own accounts"

Are admins are supposed to be able to delete regardless of that setting?
If not - then it's not a bug (maybe it's a minor enhancement?)

Change History (3)

#1 @boonebgorges
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6182]) Ensures that super admins are always able to delete users from the front end

Even when bp_disable_account_deletion() returns true, it should not prevent
users with the 'delete_users' cap from accessing the delete-account screen or
deleting accounts via bp_settings_action_delete_account().

Fixes #4355

#2 @DJPaul
12 years ago

  • Milestone changed from Awaiting Review to 1.6

#3 @johnjamesjacoby
9 years ago

  • Version changed from 1.6-beta to 1.6
Note: See TracTickets for help on using tickets.