Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4285 closed defect (bug) (no action required)

Not all correct information showing up in Activity Streams

Reported by: nickharambee's profile nickharambee Owned by:
Milestone: Priority: normal
Severity: major Version: 1.5.6
Component: Core Keywords:
Cc:

Description

I'm not sure if this a bug or some quirk in my setup, but I thought I'd post it here. I am developing a child theme of the bp-default theme, but I'm not aware of having made any changes that would affect this issue, and I'm pretty sure the issue was apparent before I started on the child theme.

I am not seeing all the activity that I would expect to see in the two activity streams. From the drop-down menu under 'show: everything' it would seem that both streams are designed to show everything including blog posts and comments, with the 'My Groups' stream showing everything related to the groups the user is a member of. I am not sure what content from the blog/comments is supposed to show in the 'My Groups' stream, maybe only posts made by members of the relevant groups?

What I am seeing is quite different to this though, which is as follows:

Both Streams: Creating Docs and Editing Docs (from the BP docs plugin)

In addition to this:

On ‘All Members’ Stream: Posts and Comments on Blog

On ‘My Groups’ Stream: Forum Topics, Creating Groups, Joining Groups, Creating tasks

This isn’t a comprehensive test, just reflects the activity I have done, but clearly there are omissions if the expected behaviour is as described above.

As a final point, if 'All Members" is supposed to show absolutely all activity on the site, including any blog posts and comments, then perhaps it would be better named "All activity"

Thanks in advance for any clarification on/attention to this matter.

Nick

Change History (4)

#1 @boonebgorges
12 years ago

It's probably a group privacy issue. The 'All Members' tab will only show activity from public groups. 'My Groups', on the other hand, will also show activity from private and hidden groups. (See #3857.) Play around to see if this looks right.

If it looks like group privacy is *not* the issue, switch back to the bp-default theme to see if the issue persists.

#2 @nickharambee
12 years ago

Thanks. I have now done some testing on this. The findings below are the same for the BP-default theme and my child theme.

Posts and Comments on the blog only show on the 'All Members' tab. I imagine this is the expected behaviour, as Blog posts are not made within groups.

Most of my groups were private, so I made one public. Previous posts on the forum still did not show on the 'All Members' tab, but new posts did show. Is there a way of getting forum posts made when the group was private to show in 'All Members' tab now that it is public? I then created a task in this public group, using the GTM plugin, and it still didn't show up in the 'All Members' tab. Presumably the expected behaviour is that it would show here? Perhaps this is a bug in GTM and I should add a support ticket on their plugin page?

As per my comments on the ticket about the missing group privacy level (#1125), I would like all of my users to be able to see all of the activity, but only members to be able to edit and post items, so I don't really want my groups to be public groups (though it looks like there isn't any other option at present, because there isn't this privacy level yet and because I'd like all activity to show up in the 'All Members' tab). Unless there's a workaround of course...

Last edited 12 years ago by nickharambee (previous) (diff)

#3 @boonebgorges
12 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the additional details, nickharambee.

Is there a way of getting forum posts made when the group was private to show in 'All Members' tab now that it is public?

No, there is nothing built into BP that does this. We definitely would not want this to be the default behavior - content produced under the expectation of privacy should not, by default, be made public at any point. A plugin could be written to do what you're asking. It would be pretty straightforward - just a matter of flipping hide_sitewide for all the group's items from 1 to 0. See #3463 and #3857.

Perhaps this is a bug in GTM and I should add a support ticket on their plugin page?

It's probably the case that GTM marks its activity items as hide_sitewide = 1. Whether this is a bug or a feature depends on your point of view, but yes, I would encourage you to talk to the dev about it.

I would like all of my users to be able to see all of the activity, but only members to be able to edit and post items, so I don't really want my groups to be public groups

As I alluded to on the other ticket, I think you *do* want to make the groups public, and then put a customization in place that keeps non-members from joining the groups, or from posting content. This could be done with about three simple template hacks. (It could probably also be built into a plugin, but it would be a lot trickier.)

It sounds like the behavior you've described is not due to a bug in BP (aside from perhaps the shortcomings described in other tickets), so I'm going to close it.

#4 @nickharambee
12 years ago

Thanks for the clarfification, and sorry if I misunderstood your communication from before about making all groups public. I have now done so, and will post a question on the support forums about how to amend the templates so that users have to request membership of a public group, and can't post content until they are a member. I'll also delete forum posts from when the groups were private and re-post now groups are public, and I'll contact the developer of the GTM plugin as you suggest.

Note: See TracTickets for help on using tickets.