Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

Last modified 3 years ago

#3843 closed defect (bug) (no action required)

"Load More" doesn't take into consideration the current scope

Reported by: r-a-y Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.2
Component: Templates Keywords:
Cc:

Description

If you navigate to any "Activity" profile subnav item and you have enough activity items so "Load More" shows up, click on the "Load More" button.

You'll notice that the current scope isn't taken into consideration, thus all sitewide activity will show up when you click on the "Load More" button.

We need to add some javascript to the Load More functionality in global.js so BP's AJAX knows what the current scope is.

I've duplicated this issue on a few browsers, but for sanity's sake if another person can replicate this issue, I'll work on this ticket.

Change History (6)

#1 @boonebgorges
8 years ago

I can't reproduce on my local installation or on testbp.org (where there's lots more content). Does this only happen on user > activity? What about the top-level activity page?

#2 @r-a-y
8 years ago

Activity directory is fine because the scope is properly passed.

It's on a user's activity subnav page.

eg.
testbp.org/members/boonebgorges/activity/mentions/
testbp.org/members/boonebgorges/activity/friends/

Try clearing your cookies first, don't go to the activity directory, but navigate to an activity subnav page. Let me know if you can duplicate this.

[EDIT]
Appears to be my Firefox install. It's probably a little too aggressive with cookie handling. Need to do more testing.

Last edited 8 years ago by r-a-y (previous) (diff)

#3 @boonebgorges
8 years ago

Yeah, still can't reproduce. That said, if it's an issue with your installation, it could be elsewhere, too. Maybe we're not using the right syntax for unsetting/resetting the relevant cookies?

#4 @r-a-y
8 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Spent some time looking into this.

I'm using a variant of Firefox that, for whatever reason, is making bp_current_action() empty and $scope false when the "Load More" button is pressed. Too weird.

All other browsers work as expected.

Closing as invalid.

#5 @johnjamesjacoby
8 years ago

  • Milestone Awaiting Review deleted

#6 @DJPaul
3 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.