Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 13 years ago

#3633 closed defect (bug) (worksforme)

Date fields do not work in languages other than English

Reported by: r-a-y's profile r-a-y Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5
Component: Extended Profile Keywords:
Cc:

Change History (2)

#1 @johnjamesjacoby
13 years ago

From that page:

In languages ​​other than English, the date fields do not work. When compared with the selected value of select field list. For example, in Spanish "april == abril" is false and the month is "----"

Let's not get into a habit of monitoring Github for support or bugs. Too much going on already.

#2 @boonebgorges
13 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Let's not get into a habit of monitoring Github for support or bugs. Too much going on already.

Oh, phooey :)

I can't reproduce the error (using the French translation; no hablo español :) ). The values on the dropdowns currently use the English months as the option value, and those values are not translatable. So it's *not* checking 'abril' == 'April'; the selected() function is always checking 'April' == 'April', no matter what language the dropdown text is in. See http://buddypress.trac.wordpress.org/browser/trunk/bp-xprofile/bp-xprofile-template.php#L611 for more information.

If I'm misunderstanding, and/or someone can provide steps to reproduce the bug, please reopen the ticket. Merci.

Note: See TracTickets for help on using tickets.