Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 9 years ago

#2714 closed defect (bug) (duplicate)

Members directory should include "Accept Friendship" button

Reported by: paulhastings0's profile paulhastings0 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Friends Keywords:
Cc: solhuebner

Description

This ticket is related to #1354

When visiting the members directory I see a list of people that I can either "Cancel Friendship", "Add Friend", or "Friendship Requested". The problem is with this last button.

Whether or not I may have initiated the friendship the button still says "Friendship Requested". This has a passive tense and gives the incorrect impression that no action needs to be taken. For new users they won't realize that they need to visit a different part of the website to accept the friendship request (which from a user standpoint is fairly confusing).

If the other person has initiated the friendship then the button should say "Accept Friendship". Clicking it would then confirm the friendship.

Change History (9)

#1 @DJPaul
12 years ago

I agree we need a different phrase for this button. I am disinclined to make it a "accept friendship" button, nor am I happy with adding a second "reject friendship" button as I feel this duplicates functionality from the pending requests page.

#2 @boonebgorges
11 years ago

How about leaving the text, but making the button point toward the pending requests page?

#3 @DJPaul
11 years ago

The problem is that a button/link that says "friendship requested" does not tell the user what will happen if they follow it.

#4 @boonebgorges
11 years ago

Good point.

I for one am not against having both an Accept and Reject button on the members directory. DJPaul, you're right that it will duplicate functionality found on the pending requests page, but this doesn't seem so bad to me. The Pending Requests screen will still be the place where most accepting/rejecting happens. The buttons on the members directory will just be for people who are browsing through members and remember 'oh yeah, I have a request from that person'.

#5 @boonebgorges
11 years ago

  • Milestone changed from 1.3 to Future Release

#6 @solhuebner
9 years ago

  • Cc solhuebner added
  • Keywords changed from friends, friendship requests to friends friendship requests
  • Severity set to normal

#7 @boonebgorges
9 years ago

  • Keywords friends friendship requests removed

Closed #4877 as a duplicate.

It sounds, from this thread and #4877, like we've got a decent idea of how to fix this issue. Now we just need someone to write a patch. Happy to include it in 1.9, if someone will make at least a first pass at the necessary functionality.

#8 @terraling
9 years ago

Sorry, I created a ticket (http://buddypress.trac.wordpress.org/ticket/5157) about the same thing without seeing this one.

In it I proposed a very minor modification which would leave existing functionality unchanged but provide theme developers with a means to differentiate the pending case depending on whether the user initiated or was the recipient of a friendship request.

Description and updated code is attached to that ticket...

#9 @boonebgorges
9 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this in favor of #5157, which has code attached

Note: See TracTickets for help on using tickets.