Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 13 years ago

#2563 closed defect (bug) (fixed)

Profile field default supercedes current value

Reported by: ethitter's profile ethitter Owned by:
Milestone: 1.5 Priority: normal
Severity: Version:
Component: Extended Profile Keywords: close
Cc:

Description

If a profile field has a default option set, the function bp_the_profile_field_options does not consider the current value of any radio, checkbox, or option types when setting the selected or checked attribute. In this case, unless a user reselects the proper values each time he/she edits his/her profile, the existing value is reset to the default.

Change History (5)

#1 @boonebgorges
14 years ago

  • Keywords reporter-feedback added

I can't reproduce this on any of my installations. Can you give more details about your setup? Versions, plugin, theme. Try deactivating all plugins but BP and switching to the default theme.

Could you also check the markup to see if the 'selected' or 'checked' attribute is being added to both the default and the saved element?

#2 @DJPaul
14 years ago

This may also be related to #2694

#3 @DJPaul
13 years ago

  • Keywords close added; reporter-feedback removed

This works on trunk; I think the patch in #2694 fixed it. It would be good if someone double-checked all the xprofile field types with default values before closing the ticket.

#4 @SergeyBiryukov
13 years ago

Works for me too. Checked all of the options which allow to set a default value:

  • Radio buttons
  • Drop Down Select Box
  • Multi Select Box
  • Checkboxes

Whatever a user has set, it stays that way.

#5 @DJPaul
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for checking, SergeyBiryukov :)

Note: See TracTickets for help on using tickets.