Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1951 closed defect (bug) (fixed)

Bug: Shortcodes doesn't work

Reported by: _dorsvenabili's profile _DorsVenabili Owned by:
Milestone: 1.2 Priority: major
Severity: Version:
Component: Keywords: shortcode code post
Cc:

Description

I have the last trunk version of BP and I have a function in functions.php like this:

Google Maps Shortcode
function fn_googleMaps($atts, $content = null) {

extract(shortcode_atts(array(

"width" => '640',
"height" => '480',
"src" =>

), $atts));
return '<iframe width="'.$width.'" height="'.$height.'" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="'.$src.'"></iframe>';

}
add_shortcode("googlemap", "fn_googleMaps");

The problem is that using the last trunk version my googlemaps shortcodes worked, but not now with the last BP trunk version of today, in other words, it must to show a google map when somebody write: [googlemap src="http://www.example.com"]. It's very important to use the shortcodes when you don't want your BP users can write code in their posts.

Attachments (1)

Screen shot 2010-02-15 at 11.38.43.png (37.8 KB) - added by _DorsVenabili 14 years ago.

Download all attachments as: .zip

Change History (6)

#1 @apeatling
14 years ago

Nothing has been changed with shortcodes - are you sure you haven'y done something that has caused this? Can you revert to a previous trunk version and test?

#2 @apeatling
14 years ago

There is an error in the function you posted, if that has anything to do with it.

#3 @apeatling
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2722]) Fixes #1951

#4 follow-up: @apeatling
14 years ago

My mistake, the template tag in use had changed. I've fixed this.

#5 in reply to: ↑ 4 @_DorsVenabili
14 years ago

Thanks and congratulations for your good work :)

Note: See TracTickets for help on using tickets.