Skip to:
Content

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#1796 closed defect (bug) (fixed)

UserBlog URL Correction for BP Not Installed in Main Site VHOST yes

Reported by: mercime Owned by:
Milestone: 1.5 Priority: major
Severity: Version:
Component: Blogs Keywords:
Cc:

Description

In the course of testing BP in different scenarios thru mirror sites of live ones (to prepare for eventuality friends/clients would want BP in their installs), I installed BP in another test site with subdomain structure in blog_id_85 and defined it in wp-config.php - WPMU 2.9.1.1, BP 1.2-trunk-r2479, VHOSt=yes

  1. Created new blog/site in admin dashboard e.g. http://community.examplesite.com/
  2. When user creates a blog in this scenario, blog URL is now e.e.

http://mercime.community.examplesite.com/

While in my other test environment with existing site with VHOST=no, if BP is installed in blog_id_103, e.g. http://samplesite.com/blogid103/ , when a user creates a new blog, the user blog URL = http://samplesite.com/mercime
It is the same level as where BP is installed.

Hopefully, in VHOST=yes, setup of new user blog would be on the same level as where BP is installed i.e. http://mercime.examplesite.com

Thank you.

Change History (8)

comment:1 johnjamesjacoby4 years ago

  • Component set to Core
  • Milestone set to 1.3

comment:2 cnorris233 years ago

  • Keywords reporter-feedback added

@mercime is this still an issue? There have been a lot of changes to WP and BP since then. Namely, the WP/WPMU merge.

comment:3 DJPaul3 years ago

  • Milestone changed from 1.3 to Awaiting Review

comment:4 mercime3 years ago

@cnorris23 @DJPaul Yes. This is still an issue. Just created a new test installation to check this.
Sorry for the delay.

WP 3.1 with BP 1.2.8

Create a Blog
/etc. etc. etc.

Blog Domain:
_(space for subdomain name) . example . com

Last edited 3 years ago by mercime (previous) (diff)

comment:5 DJPaul3 years ago

  • Component changed from Core to Blogs
  • Keywords reporter-feedback removed
  • Milestone changed from Awaiting Review to 1.3
  • Type changed from enhancement to defect

Need to check what's going on here.

comment:6 DJPaul3 years ago

Confirmed

comment:7 djpaul3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4438]) Correct domain when user creates a new site through bp-blogs, in a subdomain setup. Fixes #1796

comment:8 mercime3 years ago

Thank you DJPaul. Fix worked in new installation.

Three cheers :-)

Note: See TracTickets for help on using tickets.