Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#1722 closed defect (bug) (fixed)

bp_message_thread_to() returns error

Reported by: balbert Owned by:
Milestone: 1.2.1 Priority: major
Severity: Version:
Component: Keywords:
Cc:

Description

bp_message_thread_to(), in bp_messages_templatetags.php is giving me a mysql error. Ultimately i believe the issue is really with the get_recipient_links() call in bp_messages_class.php.

bp_get_message_thread_to() passes to get_recipients_links() $messages_template->thread->recipients which is an associative array with keys of user ids and values of objects.

get_recipients_links() then tries to loop through this associative array using non associative keys in an attempt to get the user id's and ultimately is passing an object to bp_core_get_userlink() instead of an actual user id

Change History (1)

#1 @apeatling
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.