Skip to:
Content

Opened 9 years ago

Closed 3 years ago

#1683 closed enhancement (wontfix)

Make "You were invited to group" notification more specific by using inviter name

Reported by: erich73 Owned by:
Milestone: Priority: minor
Severity: minor Version:
Component: Toolbar & Notifications Keywords: needs-patch
Cc:

Description

instead of: "You have an invitation to the group: Testing".

make this: "Group-Admin John Smith invited you to join the group Testing".

Please see Screenshot attached.

Attachments (1)

join_group_who_invited_me.gif (62.6 KB) - added by erich73 9 years ago.

Download all attachments as: .zip

Change History (9)

#1 @DJPaul
9 years ago

  • Milestone changed from 1.2 to 1.3

Needs some thought as to what happens when you have >1 invite.

#2 @boonebgorges
8 years ago

  • Component set to Core

I think that the >1 invite situation arises seldom enough where it's probably OK to just show the first user who sends you an invitation.

One consideration is that it would break the parallel phrasing of different notification texts:

  • You have a friendship request from xxx
  • You have an invitation to the group xxx
  • You have x new messages

This suggestion would break the 'You have' pattern. But this is a small consideration.

If pressed, I would agree with erich73 here, but I'm willing to entertain other thoughts before patching it.

#3 @DJPaul
8 years ago

I think the problem is the space available in the box for display. If the phrasing is changed for invitations, I think we would need to consider changing some of the other messages. For example, "Bob has sent you a new private message" or "Bob would like to be friends with you." I think the >1 issue will be more prominent for some of those.

I suggest that we think about expanding the notifications area to a full component, which would give us more room to play with, and to look at mobile operating systems for ideas on how a larger notifications area could look and work like.

#4 @DJPaul
8 years ago

  • Keywords needs-patch added
  • Milestone changed from 1.3 to Future Release

#5 @slaFFik
8 years ago

  • Component changed from Core to Notifications
  • Severity set to minor

I think we can look on Google+ - it has really great notification area (as for me).

#6 @InterMike
8 years ago

G+'s method of implementing notifications is great! I vote for that type of notifications.

#7 @boonebgorges
5 years ago

  • Summary changed from Who invited me to join a Group ? to Make "You were invited to group" notification more specific by using inviter name

#8 @DJPaul
3 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

For now, and since this hasn't had traction in years, I agree with Boone that:

I think that the >1 invite situation arises seldom enough where it's probably OK to just show the first user who sends you an invitation.

We can always revisit in future.

Note: See TracTickets for help on using tickets.