Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#1484 closed defect (bug) (worksforme)

404 Page error with IE8 when creating group or topic, FireFox OK

Reported by: Adeptris Owned by:
Milestone: Priority: critical
Severity: Version:
Component: Keywords: 2nd-opinion
Cc:

Description

Hi,
I have a problem with 404 pages and IE8 when creating a group or forum post.
The problem is only with IE8, FireFox works as expected with no errors.

buddypress.1.1.3
wordpress mu 2.8.6
wpmu bp magazine 1.0.2
Windows Vista and IE8

Logged in as Admin I get the 404 on the following URL.
http://taggeriffic.com/members/admin/groups/create/

I have tried the default theme, no plugins enabled apart from buddypress and the error page was shown.

The problem is only with the Windows Default IE browser, I have IE8, with FireFox it is working just fine where I can create groups and forum posts, so it opens up thinking around the Browser, but over 75% of browsers are IE, so I really need a solution.

If you have an IE8 Browser feel free to test creating a group,

www.taggeriffic.com

usr: test
pwd: test2010

David

Change History (13)

#2 @Adeptris
10 years ago

It looks like IE8 is have problems with the PHP functions as the Visit > Random also brings up a 404 page only in IE8 and not in FireFox

David

#3 @Adeptris
10 years ago

This came back from my ISP's forum:

The redirecting pages are being served with a 404 Page not found header, which IE must be reading and then ignoring the subsequent refresh header.
As an example here is the sort of header the app is serving, you may wish to post it back in the BuddyPress forum:

Code:

HTTP/1.1 404 Not Found
Cache-Control: no-cache, must-revalidate, max-age=0
Pragma: no-cache
Content-Length: 0
Content-Type: text/html; charset=UTF-8
Expires: Wed, 11 Jan 1984 05:00:00 GMT
Last-Modified: Mon, 21 Dec 2009 15:19:00 GMT
Server: Microsoft-IIS/6.0
X-Server: BERYLLIUM
X-Powered-By: ASP.NET
X-Powered-By: PHP/5.2.11
Set-Cookie: PHPSESSID=123f18412c96f45681b036e6fea8c123; path=/
X-Pingback: http://taggeriffic.com/xmlrpc.php
Refresh: 0;url=http://taggeriffic.com/members/exampleuser/
Date: Mon, 21 Dec 2009 15:19:00 GMT
Connection: close

This is way above my skills any experts want to chip in with a comment?

David

#4 @r-a-y
10 years ago

Hi David,

Check out this post regarding IIS and 404. Something to do with IIS' security settings.

http://forums.devshed.com/showpost.php?p=393163&postcount=14

#5 @r-a-y
10 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I don't believe this is a BP issue, so I'm resolving this ticket.

Feel free to continue posting here though.

#6 @Adeptris
10 years ago

My reseller shared Hosting Account has ASP and PHP "Dynamic Content" enabled

X-Powered-By: ASP.NET
X-Powered-By: PHP/5.2.11

Other websites on my account
http://www.adeptris.com is DotNetNuke
http://www.photographerstripod.com is DotNetNuke
http://digitalraindrops.net is opCommerce

Wordpress websites on my account
http://www.digitalweblogistics.com/blog is WP with no 404 Errors
http://www.instancesintime.com/ is WPMU with no 404 Errors
http://www.taggeriffic.com is WPMU and BuddyPress with 404 Errors

All the BuddyPress website is out the box with no custom modifications, I first done a manual upload of BuddyPress, since then I have uninstalled and reinstall with an Auto-Install, it is only the BuddyPress installation that has this error in IE.

David

#7 @Adeptris
10 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Please reconsider?

#8 @r-a-y
10 years ago

It's something to do with the $_GET variable, I'm not that familiar with IIS.

The random function calls are located here:

  • bp-core.php, specifically the bp_core_get_random_member() function.
  • bp-blogs.php, specifically the bp_blogs_redirect_to_random_blog() function.
  • bp-groups.php, specifically the groups_aciton_redirect_to_random_group() function.

A BP dev will have to take a look at it.

#9 @Adeptris
10 years ago

Ray,
many thanks I would agree as I posted a forum thread on my website earlier, it posted just fine then the 404 page came up, when I reloaded the topic was there.

So it may be the $_Get at a lower level, it gets the main pages ok, but then fails at lower levels.

Di I just wait now until someone has a look?

Many Many Thanks for your input and kind Regards

David

#11 @DJPaul
10 years ago

  • Keywords 2nd-opinion added

#12 @Adeptris
10 years ago

  • Priority changed from major to critical

Hi Andy or John,
Any News on this as I still cannot resolve it?

Kind Regards

David

#13 @apeatling
10 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Try 1.2.

Note: See TracTickets for help on using tickets.