Skip to:
Content

BuddyPress.org

Opened 15 years ago

Closed 13 years ago

Last modified 13 years ago

#1245 closed enhancement (wontfix)

I18n issues: language setting should follow user, not blog

Reported by: stripedsquirrel's profile stripedsquirrel Owned by: johnjamesjacoby's profile johnjamesjacoby
Milestone: 1.2.9 Priority: minor
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

  • The buddybar follows the language settings of the blog it is on, not of the user that is logged in. Meaning that a Spanish speaker (with language settings -> Spanish on their settings) will see a nice Spanish buddybar when on their own blog, but when they go to an English blog (the main blog for example) then the buddybar turns to English, even though it is 'their' buddybar, with their blogs and links to their profile etc. Is this by design or a bug?
  • As the translation is available, I think the language of the main blog/home theme should change according to the (logged in) user visiting it, else they are lost on the community homepage. However, currently it sticks strictly to the language settings of the main blog.

As the community homepage is almost separate from the main blog, it should follow the user-set language as well when loaded.

Change History (8)

#1 @johnjamesjacoby
15 years ago

  • Owner set to johnjamesjacoby
  • Status changed from new to assigned

I got this one. ;)

#2 @johnjamesjacoby
15 years ago

  • Milestone changed from Future Release to 1.2
  • Type changed from defect to enhancement

#3 @DJPaul
14 years ago

  • Milestone changed from 1.2 to 1.3

#4 @boonebgorges
14 years ago

  • Component set to Core
  • Milestone changed from 1.3 to Awaiting Review

It's pretty straightforward to filter buddypress_locale. The tricky part is that the textdomain is loaded pretty early in the process, before bp->loggedin_user is set. So the only way I was able to get info about the current user was with get_currentuserinfo, which adds another hit to the db.

I'm tempted to say that this is plugin territory. Leaving open for second opinion.

#5 @DJPaul
13 years ago

How do you set a language per-user in WordPress?

Last edited 13 years ago by DJPaul (previous) (diff)

#6 @boonebgorges
13 years ago

You don't. It doesn't make that much sense in wp because most consumers of content are not logged in users. I was just making a comment regarding the feasibility of allowing per-user language settings a BP-only feature.

I don't think it would be too hard to do as a plugin, so maybe we can leave it at that.

#7 @DJPaul
13 years ago

  • Resolution set to wontfix
  • Status changed from assigned to closed

Closing based on Boone's comments above, and feel that this would better as a general multisite enhancement/plugin at a lower level than BuddyPress.

#8 @johnjamesjacoby
13 years ago

  • Milestone changed from Awaiting Review to 1.2.9
  • Severity set to normal

Moving closed ticket out of Awaiting Review.

Note: See TracTickets for help on using tickets.