Skip to:
Content

BuddyPress.org

Opened 6 months ago

Closed 5 months ago

#9032 closed defect (bug) (fixed)

Prepare readme.txt for 12.0.0

Reported by: imath's profile imath Owned by: netweb's profile netweb
Milestone: 12.0.0 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: has-patch
Cc:

Description

12.0.0 is a sensitive release as we expect some 3rd party BuddyPress plugins won't be ready for the BP Rewrites API.

Instead of the regular link to the version changelog, I suggest we use a 12.0 upgrade notice a bit more elaborated.

= 12.0.0 =
- See: https://codex.buddypress.org/releases/version-12-0-0/
- Before upgrading to version 12.0.0 & if you are using one or more third party BuddyPress plugins that have not been updated lately, please make sure to download and activate the "BP Classic" backwards compatibility Add-on from your "Add New Plugin" Dashboard menu.

Change History (2)

This ticket was mentioned in PR #199 on buddypress/buddypress by @imath.


6 months ago
#1

  • Keywords has-patch added; needs-patch removed
  • Adds a donate link (required by WP readme standards)
  • Use a more elaborated upgrade notice for 12.0.0
  • Remove "old" changelog links.

Trac ticket: https://buddypress.trac.wordpress.org/ticket/9032

#2 @imath
5 months ago

  • Resolution set to fixed
  • Status changed from new to closed

In 13663:

Improve & prepare readme.txt for 12.0.0 release

  • Add a donate link (required by WordPress readme.txt standard).
  • Use a more elaborated upgrade notice for version 12.0.0 (this notice will inform Administrators they may need to download and activate BP Classic before upgrading to 12.0.0 when performing this upgrade from /wp-admin/update-core.php).
  • Remove some previous upgrade notice/changelog entries (version 8.0.0 to 9.2.0).
  • Bump stable tag to 12.0.0.

Fixes #9032
Closes https://github.com/buddypress/buddypress/pull/199

Note: See TracTickets for help on using tickets.