Skip to:
Content

BuddyPress.org

Opened 7 months ago

Closed 2 months ago

Last modified 2 months ago

#8997 closed feature request (fixed)

Disable Notification for new Private Message

Reported by: plugindevs's profile plugindevs Owned by: plugindevs's profile < plugindevs>
Milestone: Awaiting Contributions Priority: normal
Severity: normal Version:
Component: Toolbar & Notifications Keywords: has-screenshots needs-refresh needs-patch
Cc:

Description

Currently, when a member sends a private message to another member, the receiver sees a notification beside the new message indicator.
I have added a new Notification Section and an option on the BuddyPress Settings Page to enable/disable the notification for new private messages.

I suggest the attached patch for the new feature. I am also adding the Screenshot of Settings:

https://www.awesomescreenshot.com/image/43208437?key=dc742fe4717afe153f121a55f5590264

Attachments (2)

8997.patch (8.3 KB) - added by plugindevs 7 months ago.
BuddyPress-Private-Message-Notification-Options-‹-buddypress-—-WordPress.png (118.5 KB) - added by plugindevs 7 months ago.
Screenshot of Settings

Download all attachments as: .zip

Change History (10)

@plugindevs
7 months ago

This ticket was mentioned in PR #168 on buddypress/buddypress by @plugindevs.


7 months ago
#1

Currently, when a member sends a private message to another member, the receiver sees a notification beside the new message indicator.
I have added a new Notification Section and an option on the BuddyPress Settings Page to enable/disable the notification for new private messages.

I suggest the attached patch for the new feature. I am also adding the Screenshot of Settings:
https://www.awesomescreenshot.com/image/43208437?key=dc742fe4717afe153f121a55f5590264

Trac ticket: [url https://buddypress.trac.wordpress.org/ticket/8997]

#2 @imath
7 months ago

  • Keywords reporter-feedback added

Hi @plugindevs

Thanks for your patch and PR.

Why disabling the messages screen notifications in particular?
A UI to select the kind of notifications you want to disable would be more interesting imho.

Is this something that would interest most BuddyPress users?
It seems to me it's a very specific need you can easily satisfy using:
remove_action( 'messages_message_sent', 'bp_messages_message_sent_add_notification', 10 );

#3 @plugindevs
7 months ago

Hi @imath

Thanks for your feedback.

There are many users who think that the notification is different than a new message. Especially, when compared to popular social medias where notifications are different than messages. I worked on various projects where clients requested me to disable notifications when new messages came. So, from these experiences, I think this would be a useful feature.

Also, I believe the code you provided is very useful for this achievement. But there are lots of users who don't know how to code, even they aren't willing to change one line of CSS. Therefore, I think this Settings Option from Admin will be very helpful for them.

#4 @plugindevs
7 months ago

  • Keywords reporter-feedback removed

#5 @espellcaste
2 months ago

  • Keywords needs-refresh needs-patch added; has-patch removed
  • Milestone changed from Awaiting Review to Awaiting Contributions

I think this is an interesting idea, but the solution suggested is too narrow, IMO. Social media sites provide the option to refine in more details the notifications one can get, not only related to private messages.

In an app like Instagram, for example, I can pause all notifications or I can pause messages, calls, posts, etc, individually. With the suggested approach, we would need to bundle similar settings for new requests.

Also, the suggested approach doesn't take into the user's choice. The site's owner is deciding for me. There should be an option around here: https://wp.test/members/user/notifications/

Last edited 2 months ago by espellcaste (previous) (diff)

renatonascalves commented on PR #168:


2 months ago
#6

Closing pr as invalid. See the ticket for more information. :)

#7 @espellcaste
2 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

This is a duplicate of #6712

#8 @espellcaste
2 months ago

Related to #8774

Note: See TracTickets for help on using tickets.