Skip to:
Content

BuddyPress.org

Opened 10 months ago

Closed 10 months ago

Last modified 4 months ago

#8984 closed defect (bug) (fixed)

BP Add-ons Plugin admin tab: stop using buddypress wp.org account favorites to fill this tab

Reported by: imath's profile imath Owned by: imath's profile imath
Milestone: 12.0.0 Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch commit
Cc:

Description

Using this way of listing tabs isn't stable enough, we need to think about adding the Add-ons as favorites of the buddypress wp.org account.

We should use the author field of the query_plugins WP.org API endpoint and edit all Add-ons readme.txt to reflect this.

I believe it's very important to be sure to have the BP Classic plugin listed into this tab (as well as BP Attachments), and they are not so far.

I've already created these PRs on Add-ons GH repositories:

I'll add a PR to this ticket about the BP Core Administration change

Attachments (1)

CleanShot 2024-02-22 at 14.58.26@2x.png (265.7 KB) - added by espellcaste 4 months ago.

Download all attachments as: .zip

Change History (11)

#1 @imath
10 months ago

  • Summary changed from BP Add-ons Plugin admin tabs: stop using buddypress wp.org account favorites to fill this tab to BP Add-ons Plugin admin tab: stop using buddypress wp.org account favorites to fill this tab

This ticket was mentioned in PR #157 on buddypress/buddypress by @imath.


10 months ago
#2

  • Keywords has-patch added; needs-patch removed

Update arguments used to query for BuddyPress Add-ons.

Trac ticket: https://buddypress.trac.wordpress.org/ticket/8984

#3 @imath
10 months ago

  • Keywords commit added

I've just tested with the BP Search Block plugin, and it works as expected:

https://cldup.com/-gXH6t9exk.png

I'll merge all other PRs and update readme.txt on each WP.org repository asap.

#4 @imath
10 months ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 13576:

Use the author field to query Add-ons via the WP.org Plugin API

All existing Add-ons have been updated so that the contributors: header tag of their readme.txt file has been set to buddypress.

The Request we use to fetch BuddyPress Add-ons in the corresponding Plugin Admin screen will from now on look up for WordPress plugins authored by BuddyPress.

Fixes #8984
Closes https://github.com/buddypress/buddypress/pull/157

#5 @imath
8 months ago

In 13612:

Use the author field to query Add-ons via the WP.org Plugin API

Backports [13576] to branch 11.0.

See #8984
See #9007

#6 @espellcaste
4 months ago

@imath is it by design the add on option doesn't appear in a multi-site setup?

#7 @imath
4 months ago

@espellcaste the BP Add-ons Plugins tab should be added to the same level BuddyPress is. If network activated then network admin, it activated on a site, then site admin (if the Super Admin allowed Plugins menu on subsite).

#8 @espellcaste
4 months ago

But, if I'm in a MU network, and activate BuddyPress in one of the sites, only the MU network can add plugins and it is not available there.

#9 @espellcaste
4 months ago

it activated on a site, then site admin (if the Super Admin allowed Plugins menu on subsite).

I have the "Enable administration menus: Plugins" menu activated and still can't see it in the sub site.

#10 @imath
4 months ago

Right, I forgot the Add New plugin is only available on the network admin. Then you need to activate BuddyPress on the network level to get it. Unless you activated BuddyPress on the main site you can’t reach the Network Admin from another subsite.

Note: See TracTickets for help on using tickets.