Skip to:
Content

BuddyPress.org

Opened 8 months ago

Closed 8 months ago

#8981 closed defect (bug) (fixed)

bbPress will need functions update for rewrite rules v12.0.0-beta1

Reported by: vapvarun's profile vapvarun Owned by: johnjamesjacoby's profile johnjamesjacoby
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Forums Keywords: reporter-feedback
Cc:

Description

Try to link/Unlink forums with groups.

https://prnt.sc/hMl-TQSZY-hD

Fatal error: Uncaught Error: Call to undefined function bp_get_group_permalink() in ..\plugins\bbpress\includes\extend\buddypress\groups.php:616

The issue is specific to bbPress, but errors are due to BuddyPress.

I believe we can improve by avoiding fatal errors due to the removal of deprecated functions from BuddyPress, as the removal of all of them defeats the purpose of defining them in the first place.

We can keep loading deprecated functions up to the last major version update, e.g., v12.0 contain all deprecated functions after v11.0 without defining the following constant; it will avoid fatal errors like the above and give developers time to improve their codes and 3rd party dependencies.

define( 'BP_LOAD_DEPRECATED', true );

Change History (6)

#1 @imath
8 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Hi @vapvarun

I've already submitted a patch about it: https://bbpress.trac.wordpress.org/ticket/3576

#2 @imath
8 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#3 @imath
8 months ago

  • Keywords reporter-feedback added

I've read your description too quick @vapvarun sorry.

Were you using the 12.0.0-beta1 package or BP trunk?

If you were using 12.0.0-beta1 package and did not get deprecated notices that's very annoying, because you should have latest 2 versions deprecated functions covered with these notices.

See #8687

#4 @imath
8 months ago

I've just tested with 12.0.0-beta1, I do have 12.0.0 deprecated notices, without the need to set any constant eg:

[21-Aug-2023 23:01:51 UTC] PHP Deprecated:  Function bp_get_group_permalink is <strong>deprecated</strong> since version 12.0.0! Use bp_get_group_url() instead. in /wordpress.stable/wp-includes/functions.php on line 5445

#5 @vapvarun
8 months ago

Sorry, I was using the GitHub master branch. I can confirm that beta displays those notices but not as a fatal error. @imath

#6 @imath
8 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Great thanks a lot for your confirmation @vapvarun 😍. I'm feeling better 😅.

I guess we can safely close this ticket.

Note: See TracTickets for help on using tickets.