Skip to:
Content

BuddyPress.org

Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#8447 closed defect (bug) (fixed)

activate link doesn't work

Reported by: chrisbarry Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Core Keywords: reporter-feedback
Cc:

Description

Hi,

(I'm sorry if this is the wrong place for this, I assume this isn't a bug, more a config issue of mine, but the forum wouldn't let me post)

My users are registering and being given signup links like this

/activate/dwiuhsaefiubeuibfse/

This doesn't work, it's as if the 2nd url segment doesn't get picked up.

This does work

/activate/?key=dwiuhsaefiubeuibfse

I've been changing the function in bp_core_signup_send_validation_email to

'activate.url' => esc_url( trailingslashit( bp_get_activation_page() ) . "<strong>?key=</strong>{$key}" ),

But this will just get overriden the next time the plugin updates?

What is the correct way to solve this? Is it my webserver not passing the url to a function correctly? I am hosting on wp-engine.

Or is it actually a Buddypress problem?

Change History (8)

#1 @imath
6 months ago

Hi,

I don't think it's a BuddyPress problem, as stopping using the query parameter was done to fix this issue #5831

When the new user clicks on the activate link he received in his email box, he should reach the activation form, see screen cap below:

https://cldup.com/LEGLRZiWAh.png

He then just need to click on the activate button.

If you need to change the activate.url you can do so using the bp_before_send_email_parse_args filter.

#2 follow-up: @imath
5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

#3 @chrisbarry
5 months ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Hi,

Sorry for the slow reply, so the issue is a bit subtle, and I am working on a really large wp installation, with much going on, wihch I didn't build, so forgive me.

This link works:

https://site.com/activate/87569236972865982365/ - This shows activation screen

This doesn't:

https://site.com/activate/1234abcd456/ - This redirects to login screen

So it looks like having an alphanumeric number breaks the routing, and it heads off to require login.

I'm now going to dig into why this could be, it feels fairly subtle, but lets see.

If you have any ideas, let me know, and thanks for the response at all.

#4 in reply to: ↑ 2 @chrisbarry
5 months ago

Replying to imath:

Also, the file that is resolving this page is:

wp-content/plugins/buddypress/bp-templates/bp-legacy/buddypress/members/activate.php

not

wp-content/plugins/buddypress/bp-themes/bp-default/registration/activate.php

is there something about bp-legacy / bp-default going on, or is that normal?

Thanks

#5 @imath
5 months ago

  • Keywords reporter-feedback added
  • Milestone set to Awaiting Review

Hi thanks for your reply. I need more information about your Website configuration as it doesn't seem to be a standard one.

  • this kind of link: site.url/activate/1234abcd456/ is typically generated by a WordPress multisite config.
  • this kind of link: site.url/activate/87569236972865982365/ is typically generated by a WordPress single site config.

Could you reply to these questions:

  • How is WordPress installed: Multisite or not ?
  • Are there any specific constant defined into your wp-config.php file that are not "standard" (different from the one you could find into the wp-config-sample.php or different than the one that are generated by WordPress during Network installation) ?
  • How is installed BuddyPress if it's a multisite config: network widely, on the main site of the network, on a subsite of the network ?
  • Are there any BP specific constant defined into your wp-config.php file or a potential bp-custom.php file ?
  • What is the name of the active theme where BuddyPress is installed ?

Thanks in advance for your replies.

#6 @chrisbarry
5 months ago

How is WordPress installed: Multisite or not ?

Not Multisite

Are there any specific constant defined into your wp-config.php file that are not "standard" (different from the one you could find into the wp-config-sample.php or different than the one that are generated by WordPress during Network installation) ?

Apart from db settings and keys/salts, there is only this:

/

  • WordPress Database Table prefix. *
  • You can have multiple installations in one database if you give each
  • a unique prefix. Only numbers, letters, and underscores please! */

$table_prefix = 'wp_';

/* That's all, stop editing! Happy publishing. */

/ Absolute path to the WordPress directory. */
if ( ! defined( 'ABSPATH' ) ) {

define( 'ABSPATH', dirname( FILE ) . '/' );

}

/ Sets up WordPress vars and included files. */
require_once ABSPATH . 'wp-settings.php';

How is installed BuddyPress if it's a multisite config: network widely, on the main site of the network, on a subsite of the network ?

It is not a multisite (at least this does not exist - define( 'WP_ALLOW_MULTISITE', true );)

Are there any BP specific constant defined into your wp-config.php file or a potential bp-custom.php file ?

There is no bp-custom.php and I've sent you all there is apart from db and salts info (not that this is a particularly important site, but I guess no need to share them)

What is the name of the active theme where BuddyPress is installed ?

it's the boss child theme (hence a custom boss)

Let me know if that helps at all, and thanks very much for helping (I've got my hack from above working, but it reverts each time something updates, obviously) I could patch the url as you've suggested, but be nice to fix it properly.

Cheers,

Chris

Version 0, edited 5 months ago by chrisbarry (next)

#7 @imath
5 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Ok, I see you're using the "BuddyBoss" platform, they are using a fork of BuddyPress, so I can't help you, I advise to contact their support team.

#8 @chrisbarry
5 months ago

Haha, fair enough, thank you :) (I inherited this system from someone else)

Note: See TracTickets for help on using tickets.