Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#8436 closed defect (bug) (worksforme)

Error from bp-groups-template.php on line 602

Reported by: alexhal's profile alexhal Owned by:
Milestone: Priority: normal
Severity: normal Version: 7.1.0
Component: Groups Keywords:
Cc:

Description

Hi we are getting
Warning: Creating default object from empty value in /home/demoswplms/public_html/wp-content/plugins/buddypress/bp-groups/bp-groups-template.php on line 602

error on group page , we are using shortcodes on group page to show groups information like group avatar, group title etc .

We are not overwriting global $bp var or global $groups_template var but still the issue is appearing

Change History (3)

#1 @imath
3 years ago

  • Component changed from Core to Groups
  • Keywords reporter-feedback added
  • Priority changed from high to normal

Hi,

I don’t see anything unusual in the source code. If you are using the bp_get_group_id() function outside of a group loop without passing a group object, then you can get an error, are you sure the shortcode is properly using this function ?

#2 @imath
3 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Latest improvements introduced about Group template functions should have fixed this issue. See #6749

#3 @alexhal
2 years ago

Hi yes that was the case the loop was missing before we are using bp_get_group_id fx. Thanks.

Note: See TracTickets for help on using tickets.