Skip to:
Content

BuddyPress.org

Opened 3 months ago

Closed 3 months ago

#8403 closed defect (bug) (fixed)

Replying to an activity comment is forbidden 😱

Reported by: imath Owned by: imath
Milestone: 7.0.0 Priority: high
Severity: major Version:
Component: Activity Keywords: has-patch
Cc:

Description

I've just found a regression we (well I 😳!) introduced in [12735]. Commenting an activity works fine. But replying to an activity comment fails because we are not using the main activity ID to build the nonce but the replied comment ID one.

The attached patch is fixing the issue 😅

I'll commit it shortly.

Attachments (1)

8403.patch (1.4 KB) - added by imath 3 months ago.

Download all attachments as: .zip

Change History (2)

@imath
3 months ago

#1 @imath
3 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 12805:

Do nonce check the right way when handling activity comment replies

[12735] introduced a regression preventing users from replying to an activity comment. As we were using the wrong ID to build the nonce, the nonce check was failing during the new_activity_comment Ajax request.

Fixes #8403

Note: See TracTickets for help on using tickets.