Skip to:
Content

BuddyPress.org

Opened 3 weeks ago

Closed 2 weeks ago

#8386 closed defect (bug) (fixed)

Search does not work in Group Activity -- error 400

Reported by: corsky Owned by: imath
Milestone: 7.0.0 Priority: normal
Severity: normal Version: 6.3.0
Component: Groups Keywords: has-patch commit
Cc:

Description

Hi

I’m using buddypress with BP-Nouveau and I’ve noticed that when I disable the custom front page for groups, the search function in the directory is not working, while it is working if the custom front page is enabled. Is it a bug? or there is another way to make it to work? , I see a 400 bad request when I click the search button in Developer Tools (F12).
I’ ve disabled all the plugins and I have no custom code, but kept BP-Nouvau and ocean wp theme and still it does not work. Unfortunately the only difference is that the “enabled/disabled custom front pages for groups” determines whether the search works or not.
When I inspect the “search” in the activity group page the references are different dipending on the enabling of the Custom front pages for groups.
Here is a link that shows which search buttons do not work : https://www.x-simili.it/booking/

Thank you so much
Corrado

Attachments (1)

8386.patch (714 bytes) - added by imath 3 weeks ago.

Download all attachments as: .zip

Change History (10)

This ticket was mentioned in Slack in #buddypress by vapvarun. View the logs.


3 weeks ago

#2 @imath
3 weeks ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Contributions to 7.0.0
  • Owner set to imath
  • Status changed from new to assigned

Thanks for your feedback. We are going to try to fix the issue asap.

#3 @vapvarun
3 weeks ago

able to replicate it https://demo.buddyxtheme.com/groups/terminator/
Failed to load resource: the server responded with a status of 400 ()
/wp-admin/admin-ajax.php:1

@imath
3 weeks ago

#4 @imath
3 weeks ago

  • Keywords has-patch reporter-feedback added; needs-patch removed
  • Priority changed from high to normal
  • Severity changed from major to normal

So if I rephrase the description of the bug like this :

If the Group's custom front page is deactivated, searching into a single group's activities is failing. Am I right ?

If so, 8386.patch should fix the issue.

Otherwise what is the directory in "search function in the directory is not working" ? The Groups directory page, The Activity directory page ?

#5 @corsky
3 weeks ago

Hi Math
Thank you so much! Yes, that's exactly what I meant, and it works great for "search". I noticed that, under the same conditions, the filter in the box next to the search in the same screen does not work either. Can you fix this too?

Thanks again
Corrado

#6 @imath
3 weeks ago

  • Keywords needs-refresh added; has-patch reporter-feedback removed

Hi @corsky

Awesome, thanks for the confirmation, I will fix the activity filter asap.

#7 @imath
3 weeks ago

  • Keywords has-patch commit added; needs-refresh removed

It's actually already fixed on our development version see [12703]. It will be available in 7.0.0, as well as the search fix 👍

Last edited 3 weeks ago by imath (previous) (diff)

#8 @corsky
2 weeks ago

Great !!!
Everthing works now!!

Yu are a genius!

Thanks
Corrado

#9 @imath
2 weeks ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 12774:

BP Nouveau: make sure Ajax searching in single Group works as expected

When the custom front template is not active, the activity template is loaded as the Group's home page. In this case we need to make sure the search form selectors IDs are including the "activity" reference instead of the "home" one. If the Activity component is not active, Group's home is the members template: we also need to make sur the corresponding search form selectors IDs are including the "member" reference instead of the "home" one.

Props corsky, vapvarun

Fixes #8386

Note: See TracTickets for help on using tickets.