Skip to:
Content

BuddyPress.org

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#8365 closed enhancement (fixed)

Renovate the create a blog form

Reported by: imath Owned by: imath
Milestone: 7.0.0 Priority: normal
Severity: normal Version: 1.0
Component: Blogs Keywords: has-patch
Cc:

Description

Trying to reproduce the issue described there #8351, I've noticed the form to create a new blog for logged in users was getting old and was doing a step for subdomain installs that was redundant. As wpmu_validate_blog_signup() is building the new site URL, we don't need to redo it.

Attachments (1)

8365.patch (22.2 KB) - added by imath 4 months ago.

Download all attachments as: .zip

Change History (4)

@imath
4 months ago

This ticket was mentioned in Slack in #buddypress by imath. View the logs.


4 months ago

#2 @imath
4 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 12734:

Blogs: renovate the create a blog form

This blog form let logged in users create sites. It aged badly since version 1.0 and we were unnecessarily resetting the blog domain for subdomain installs though wpmu_validate_blog_signup() is already generating this domain.

Fixes #8365

#3 @imath
4 months ago

In 12750:

i18n: improve translators comments

  • Add a missing translators comment into the src/bp-blogs/bp-blogs-template.php.
  • Make sure translators comments are the same when the string to translate is.

Antiprops imath

See #8365
See #8369

Note: See TracTickets for help on using tickets.