Skip to:
Content

BuddyPress.org

Opened 4 years ago

Closed 17 months ago

#8354 closed defect (bug) (worksforme)

Oembed issue in activities

Reported by: etatus's profile etatus Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.2.0
Component: Activity Keywords:
Cc:

Description

When I enter a Facebook link in an activity update, the content shown after sending (via AJAX) is not correct (it is uncomplete, with weird format). After reloading the activity page, everything is shown correctly. Please see attached screenshots.

Attachments (2)

bp_screenshot1.jpg (160.5 KB) - added by etatus 4 years ago.
The post content is not correctly loaded after sending the link via ajax
bp_screenshot2.jpg (197.7 KB) - added by etatus 4 years ago.
The post content is shown correctly after reloading the page

Download all attachments as: .zip

Change History (5)

@etatus
4 years ago

The post content is not correctly loaded after sending the link via ajax

@etatus
4 years ago

The post content is shown correctly after reloading the page

#1 @imath
4 years ago

  • Keywords reporter-feedback added
  • Priority changed from high to normal
  • Severity changed from major to normal

Hi @etatus

I've just tested with

  • WordPress 5.6-alpha (non Multisite config),
  • BuddyPress 7.0-alpha,
  • BP Nouveau as the active template pack,
  • Twenty Nineteen theme active.

It works as expected. I can't replicate your issue. I believe this could be caused by the theme or another plugin you are using.

Unless you can give me more information, I think we should close this ticket.

#2 @etatus
4 years ago

Hmmm, It seems it has some random component, sometimes it works, and mostly not in my installation (GeneratePress Theme). Could you point me to the file/functions in charge of processing the ajax request on activity update submit? I'll try to debug to find out what is the problem (maybe a JS conflict/error?).

Thank you!

#3 @imath
17 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.