Skip to:
Content

BuddyPress.org

Opened 11 months ago

Closed 8 weeks ago

#8337 closed defect (bug) (fixed)

Avatar url is wrongly escaped in "what's new form"

Reported by: hz_i3 Owned by: imath
Milestone: 8.0.0 Priority: normal
Severity: normal Version: 6.1.0
Component: Templates Keywords: has-patch commit
Cc:

Description

To reproduce the problem:

Turn on "show avatar" of WordPress on "/wp-admin/options-discussion.php"
Change "Default Avatar" to "Retro (Generated)"
Create a new user without no avatar
Log in with that user
Go to its member page
A Gravatar Logo is shown rather than a Retro style avatar

The problem is the url is escaped (seen from the screenshot)... If I replace "&" with "&", the Retro style avatar will show.

I tried to look into PHP source code (mainly the bp-nouveau directory) but I cannot find where it is escaped, maybe in JS code

Screenshot:

https://i.imgur.com/RIAm8AG.png

Attachments (1)

8337.patch (953 bytes) - added by imath 8 weeks ago.

Download all attachments as: .zip

Change History (3)

@imath
8 weeks ago

#1 @imath
8 weeks ago

  • Component changed from Activity to Templates
  • Keywords has-patch commit added
  • Milestone changed from Awaiting Review to 8.0.0

Hi @hz_i3

Thanks for your report and good catch about this issue. I'll commit the above fix asap.

#2 @imath
8 weeks ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 12896:

Make sure the Activity Post Form uses the right default Gravatar

The Nouveau JavaScript template was wrongly escaping the Gravatar URL.

Props hz_i3

Fixes #8337

Note: See TracTickets for help on using tickets.