Skip to:
Content

BuddyPress.org

Opened 3 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#8335 closed defect (bug) (fixed)

REST API user registration endpoint not sending validation email

Reported by: dariobf Owned by:
Milestone: 7.0.0 Priority: highest
Severity: major Version:
Component: REST API Keywords: dev-feedback
Cc:

Description

Hi,
if you try to register a new user through BP REST API members endpoint, you won't receive confirmation mail.

Also, register the user as confirmed which is a high problem because of RGPD compliance.

Change History (4)

#1 @dariobf
3 weeks ago

I think that having that functionality in buddypress core, should be there an endpoint parameter which allow you to say "Hey, register that user as non confirmed and send the validation mail". Something like "validation:true|false"

#2 @espellcaste
2 weeks ago

  • Keywords dev-feedback added
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

It is important to understand that the members endpoint is a mirror of the WordPress user endpoint with some BuddyPress sugar on top of it.

Meaning that if you want to add a user and have the confirmation email sent, you need to use the user signup endpoint: https://developer.buddypress.org/bp-rest-api/reference/signup/#signup-a-user-with-or-without-a-blog

That's the correct way to signup a user. The app should register the user using this endpoint
and the API will send the confirmation email.

If you want to force a user in, you can use the Members endpoint: https://developer.buddypress.org/bp-rest-api/reference/members/#create-a-member

No confirmation email will be sent and like you mentioned, the user will be confirmed.

So I'm closing this ticket as invalid since my understanding of it is that you are using the wrong endpoint to get what you need.

:)

Last edited 2 weeks ago by espellcaste (previous) (diff)

#3 @espellcaste
2 weeks ago

  • Resolution changed from wontfix to no action required

#4 @espellcaste
2 weeks ago

  • Milestone set to 7.0.0
  • Resolution changed from no action required to fixed
Note: See TracTickets for help on using tickets.