Skip to:
Content

BuddyPress.org

Opened 17 months ago

Last modified 5 months ago

#8303 reopened defect (bug)

Bug with buddypress hidden group when bbpress activated

Reported by: tskpbls Owned by: johnjamesjacoby
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 6.0.0
Component: Groups Keywords: needs-testing
Cc: Joost, Abrahams

Description

Hi there,

I am here to report the following issue :

On a multisite install with wp 5.4.1, with buddypress (6.0.0) & bbpress (2.6.4), setting up a forum for a group that is supposed to be hidden makes this group not accessible to admin or group creator. (Myself, as a super-admin/group creator/group admin cant reach my hidden group when bbpress is activated.)

This occurs only when bbpress is activated multisite or single subsite and a buddypress group (buddypress installed network wide) is set to hidden. It seems to work ok with group set as private, or public.

This is a bug, replicated by a bp support forum member.

Details and screenshots on this buddypress support forum : https://buddypress.org/support/topic/bug-with-buddypress-hidden-group-when-bbpress-activated/

Thanks !

Change History (9)

This ticket was mentioned in Slack in #buddypress by joost. View the logs.


16 months ago

#2 @johnjamesjacoby
16 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Up Next
  • Owner set to johnjamesjacoby
  • Priority changed from normal to high
  • Status changed from new to assigned

Hi there! It is likely this will require a fix on the bbPress side of things, but I will make sure it gets tracked and fixed either way.

Sorry for the problem. Thank you for reporting it! 🙌

#3 @imath
10 months ago

  • Milestone changed from Up Next to 8.0.0

Let's try to fix this during 8.0.0 dev cycle.

#4 @imath
5 months ago

  • Keywords reporter-feedback added; needs-patch removed
  • Priority changed from high to normal

Hi @tskpbls

Sorry for my late reply, I've just tested with:

BuddyPress and bbPress are network activated. I wasn't able to replicate your issue. As a super-admin or regular member, I can create, access hidden groups even if they have a bbPress forum.

Maybe this was fixed in bbPress?

Can anyone confirm or help me to reproduce the issue?

#5 @imath
5 months ago

  • Milestone 8.0.0 deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

Without more details from the reporter, I'm closing the ticket. Don't hesitate to reopen it if needed.

#6 @Joost Abrahams
5 months ago

  • Cc Joost Abrahams added
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hi @imath.

For me this bug is still happening.
That is hidden groups are not show on frontend.
In wp-admin hidden groups are show and accessible.

WordPress 5.7.2 multisite
BuddyPress 7.3.0 network activated
bbPress 2.6.6 on main site activated

I deactivated all plugins expect , buddypress, bbPress and BP xProfile WordPress User Sync.
but the bug remains.

More info about my setup :
https://www.mantablog.nl/my-setup/

#7 @imath
5 months ago

  • Keywords needs-testing added; reporter-feedback removed
  • Milestone set to Awaiting Review

Thanks for your feedback, I understood bbPress was activated on the network. I'll test again with bbPress activated on the main site.

#8 follow-up: @johnjamesjacoby
5 months ago

Hidden groups do not appear in directory listings.

#9 in reply to: ↑ 8 @Joost Abrahams
5 months ago

Replying to johnjamesjacoby:

Hidden groups do not appear in directory listings.

Yes, only on the frontend, the count of the number is right. hideen groups are counted

Note: See TracTickets for help on using tickets.