Skip to:
Content

BuddyPress.org

Opened 6 months ago

Last modified 6 months ago

#8239 new defect (bug)

Group activity stream filter not working with Nouveau, fine with Legacy

Reported by: CarolineElisa Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Activity Keywords:
Cc:

Description

The 'search anything' field and filter dropdown on the Group Activities stream both do nothing. In the console I see the error 'Failed to load resource: the server responded with a status of 400 (Bad Request)' for the /wp-admin/admin-ajax.php file.

When I switch to the Legacy theme the filter dropdown works as expected, there is no search.

I have disabled all plugins except BuddyPress and bbPress and am using Twenty Sixteen. I also tried disabling bbPress and using Twenty Twenty and Twenty Nineteen.

Here is an example group page with the issue: https://www.carolineelisa.com/forum/groups/second-test-group/

Change History (2)

#1 @CarolineElisa
6 months ago

  • Component changed from Core to Activity

After some more testing, including a fresh WP install, I found that the issue only occurs on the group front page when 'Enable custom front pages for groups' is unchecked and hence shows the activity stream on the front page

When this is checked and the activity stream has its own tab then the filter works fine on the tab.

#2 @imath
6 months ago

Hi @CarolineElisa

Thanks a lot for your feedback and for narrowing the issue. I'll try to have a look at it asap.

Note: See TracTickets for help on using tickets.