Skip to:
Content

BuddyPress.org

Opened 7 months ago

Closed 5 months ago

#8202 closed enhancement (fixed)

Setting up Group_Type via Group REST API Request

Reported by: ExoConsult Owned by: espellcaste
Milestone: 6.0.0 Priority: normal
Severity: normal Version: 5.0.0
Component: REST API Keywords:
Cc:

Description

There's a missing argument when creating or updating a group via REST API : Group_Type.

For the moment, it's not possible to set up Group_Type with a call to the REST API creation group endpoint.

Call_Create : POST {{host}}/wp-json/buddypress/v1/groups/
Call_Update : POST {{host}}/wp-json/buddypress/v1/groups/%d

Group defined with bp_groups_register_group_type.

In WordPress API, you can set up post format via the rest api by using the arg "format".

Thanks,
Didier

Change History (3)

#1 @imath
7 months ago

  • Milestone changed from Awaiting Review to 6.0.0
  • Type changed from enhancement to defect (bug)

Hi,

Thanks for your feedback. I agree this is something we need to work on. As for now we're maintaining the BP REST API from a distinct repo, you'll be able to follow our progress on:
https://github.com/buddypress/BP-REST/issues/259

#2 @espellcaste
6 months ago

  • Owner set to espellcaste
  • Status changed from new to assigned
  • Type changed from defect (bug) to enhancement

Support for creating and updatting groups and members with their types were added to the BP REST API: https://github.com/buddypress/BP-REST/issues/259

@imath How are you handling situations like those? Do you close the ticket here or wait for the release to be published first?

#3 @imath
5 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

I think we can close this ticket now the issue is fixed in the GH plugin.

Note: See TracTickets for help on using tickets.