Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#818 closed defect (bug) (fixed)

In WPMU Trunk Filter bp_core_filter_buddypress_theme_root doesn't seem to fire in bp_core_get_buddypress_themes() for bp-core-admin.php

Reported by: ev3rywh3re Owned by:
Milestone: Priority: major
Severity: Version:
Component: Keywords: bp_core_filter_buddypress_theme_root, bp-core-admin
Cc: ev3rywh3re

Description

This is using WordPress MU trunk, and I am aware that there is more work to merge in the changes for WordPress Core 2.8.x. So this may be due to changes in WordPress MU Trunk that have affected BuddyPress.

For some reason the theme dropdown under the BuddyPress General settings is showing the default list of WordPress themes instead of the themes in bp-themes.

I haven't tracked down the reason yet. But I do see that this is not firing in bp-core.php.

	add_filter( 'theme_root', 'bp_core_filter_buddypress_theme_root' );
	$themes = get_themes();

The 'theme_root' filter in get_themes() seems to be returning the standard wp-content/themes directory for some strange reason.

This occurs on two systems I test on. One is with a hosting company and the other is a server I maintain directly.

Attachments (1)

buddypress-t818-r1595.txt (660 bytes) - added by ev3rywh3re 11 years ago.
Put a bp_core_filter_buddypress_theme_root in bp_core_add_admin_menu

Download all attachments as: .zip

Change History (6)

#1 @ev3rywh3re
11 years ago

Confirming that WordPress MU Trunk r1806 has this issue.

#2 @ev3rywh3re
11 years ago

Really bugging me, this should be working!

This cleared up on a few WordPress MU test sites as of WordPress MU 2.8 Beta r1834, but the theme_root filter is not running on one test website configured from a sub-directory location like http://example.com/stupid_place_for_wpmu/. This is a Dreamhost PS site (I know - there's your problem).

Which is really odd since I have another test site on a server that I maintain using an apache alias configuration that works fine example http://otherexample.com/other_stupid_place_for_wpmu/.

I will try to do another test site in a sub-directory on the server I maintain, but this may be an issue with Dreamhost or their php version.

@ev3rywh3re
11 years ago

Put a bp_core_filter_buddypress_theme_root in bp_core_add_admin_menu

#3 @ev3rywh3re
11 years ago

I can reproduce this on multiple systems as of WordPress MU r1839.

The only fix I have so far was to place add_filter( 'theme_root', 'bp_core_filter_buddypress_theme_root' ) in the bp_core_add_admin_menu() function. There is probably a better fix than that.

#4 @(none)
11 years ago

  • Milestone Core 1.1 deleted

Milestone Core 1.1 deleted

#5 @apeatling
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 1.0.3, thanks.

Note: See TracTickets for help on using tickets.