Skip to:
Content

BuddyPress.org

Opened 5 months ago

Last modified 5 months ago

#8114 new defect (bug)

Hidden Groups Remain Hidden, Even To Admins

Reported by: rach24smith Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.4.0
Component: Groups Keywords: reporter-feedback has-screenshots
Cc:

Description

Hello,

When I create a hidden group, the group is not visible in the front end from anyone who is in the group. I created a group (I tried both front end creation and back end creation) and the group remains hidden from all users on the page. I have read previous tickets on this matter and I have selected the "y groups tab", not just the "All groups tab" and I still see nothing. On the "All Groups" tab, there is a bubble with the number 7 in it, and in the "My groups" tab, there is also a bubble with the number 7 in it. It also says "Viewing 1-7 of 7 groups", however only 1 is visible. From the back-end, the hidden groups are accessible, however, not all users will have access to the back-end so that does not satisfy our needs.

We use the them wOffice and I logged a ticket with them, however, they directed me here and said that it is an issue with your software....

I am using WordPress version 5.2.2, and Buddypress version 4.4.0. I have also tried disabling all plugins, nad the issue still persists.

Website: https://dev.haldimandcounty.ca/intranet/
Gorups: https://dev.haldimandcounty.ca/intranet/groups/
An example of a hidden group: https://dev.haldimandcounty.ca/intranet/groups/hidden-group/

Attachments (1)

Issue_With_Hidden_Groups.PNG (668.1 KB) - added by rach24smith 5 months ago.
A screenshot of the My Groups tabfor an admin who has 6 hidden groups created by admin.

Download all attachments as: .zip

Change History (2)

@rach24smith
5 months ago

A screenshot of the My Groups tabfor an admin who has 6 hidden groups created by admin.

#1 @imath
5 months ago

  • Keywords reporter-feedback has-screenshots added

Hi @rach24smith

Thanks a lot for your feedback. I'm sorry I don't manage to reproduce the issue. You'll find below a screencap of the "My Groups" tab I've made being logged in as a regular member and using the Twenty Nineteen theme. As you can see 127 Hours & Braveheart are two hidden groups and they are listed.

https://cldup.com/vfvCEvbrGL.png

I suggest you to deactivate all plugins (except BuddyPress), temporarly remove the potentiel files into /wp-content/mu-plugins, rename the file /wp-content/plugins/bp-custom.php to whatever you like if it exists, activate one of the WordPress default themes (eg: Twenty Nineteen or TwentySeventeen) to check if the issue is still there.

I suspect a plugin/theme/ or a specific BuddyPress hook to alter the Group Loop's query argument.

Note: See TracTickets for help on using tickets.