Skip to:
Content

BuddyPress.org

Opened 15 years ago

Closed 15 years ago

#808 closed defect (bug) (fixed)

Timezone Issue

Reported by: pb1285n's profile pb1285n Owned by:
Milestone: 1.1 Priority: major
Severity: Version:
Component: Keywords:
Cc:

Description

Say the server timezone is -5 and someone changes their timezone to -1. If they post after this it doesn't appear to take into account the difference in timezone. So if someone posted something at the same time one person in -5 and one person in -1 it would appear that the person in -1 posted 4 hours ahead of the person in -5. The same goes if someone made their timezone behind that of the servers.

The problem this causes is that if you turn on the recent blog posts widget or sitewide activity, you'll have people stuck on the top of the list for long periods of time, or people who don't show up on the list at all because it appears as if they posted their blog hours before they actually did.

To reproduce this just change the timezone of a user and post a topic. If you'd like to see an example you can try it at sims3legacy.com

Change History (2)

#1 @apeatling
15 years ago

  • Milestone set to 1.1

#2 @apeatling
15 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [1785]) Forcing all time comparisons in BuddyPress to be converted to GMT. Fixes #808

Note: See TracTickets for help on using tickets.