Skip to:
Content

BuddyPress.org

#8056 closed defect (bug) (fixed)

{{recipient.name}} Email Token in Salutation shows {{recipient.username}} in Account Activation Mail

Reported by: andbecker87 Owned by: boonebgorges
Milestone: 5.0.0 Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Hi,

I have found in Issue with the Mail send when "Recipient has registered for an account."
The Salutation part shows the recipient.username instead of recipient.name for that mail.

I found no way to fix this myself. It would be awesome if someone could look into this.

Currently I am running Buddypress locally on OSX under PHP 7.0

Cheers,
Andreas

Change History (2)

#1 @boonebgorges
19 months ago

  • Milestone changed from Awaiting Review to 5.0.0

I believe the issue is that, at this point in the registration process, the user's display name hasn't been saved to the xprofile table - the user doesn't even exist at this point, just a signup - so the data's not available in the correct structure.

That said, the data is generally available as part of the signup meta. Let's make the change.

#2 @boonebgorges
19 months ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 12349:

Use display name as salutation in signup emails.

Previously, the user login was used, because the display name was not
yet saved in the database. However, we can generally extract the user's
provided display name from the signup's meta fields.

Fixes #8056.

Note: See TracTickets for help on using tickets.