Skip to:
Content

BuddyPress.org

Opened 2 years ago

Closed 2 years ago

#8017 closed defect (bug) (worksforme)

MySQL 8 : The group component in the "Nouveau" template does not display a list of groups

Reported by: krioteh Owned by:
Milestone: Priority: high
Severity: major Version:
Component: Groups Keywords: reporter-feedback
Cc:

Description

When we go to the group directory, nothing is displayed.
In the eighth version of MySQL, a new "Group" function appeared - perhaps this is the reason ...

Attachments (1)

buggg.PNG (24.8 KB) - added by krioteh 2 years ago.
How the problem looked

Download all attachments as: .zip

Change History (6)

#1 @boonebgorges
2 years ago

  • Keywords reporter-feedback added

Hi @krioteh - It's highly unlikely that a new MySQL function would affect the groups component in virtue of the word 'group', since our component="groups" check (and related checks) always look at the string group, wrapped in quotes.

You mention that your problem is specific to Nouveau. Does this mean that it works OK in Legacy? Did it start when you upgraded to a specific version of BuddyPress? Is it true across all group directories (/groups/ as well as /members/you/groups)?

#2 @krioteh
2 years ago

  • Keywords reporter-feedback removed

Yes, everything is fine in Legasy mode.
The problem is observed wherever enumeration of groups is involved. I find it difficult to answer which version it started from, just for some reason, "Nouveau" didn't work for me in production (in MySQL8), and then I switched to MariaDB and the group directories started working.
Hmm ... I'll try two different databases on a clean installation today. Maybe I hurried with the conclusions and the problem is something else.
By result I will inform.

@krioteh
2 years ago

How the problem looked

#3 @boonebgorges
2 years ago

  • Keywords reporter-feedback added; needs-patch removed

Thanks for the details. The first thing I'd suggest is opening the browser console to look for errors related to the AJAX request that fetches groups. It's likely that you have a plugin conflict or some configuration issue that's causing the request to fail. If so, it's likely not a bug in BuddyPress itself.

#4 @krioteh
2 years ago

The only active plugin is BuddyPress. The console is clean (well, except "JQMIGRATE: Migrate is installed with logging active, version 1.4.1")
I do not understand....
With the new installation of BuddyPress, this problem does not appear.
When upgrading from version 2.9 ... (as it was on my production site) - endless waiting for the download of the list of groups ...
Although, wait a minute ....
Yes, the problem is in the plugin, which for many years lies in the "mu-plugins" for automatic transliteration of links and files.
But why for a clean installation the problem does not appear I do not understand :) ....
In any case, this is really not a problem BuddyPress. Sorry for the false alarm.

Last edited 2 years ago by krioteh (previous) (diff)

#5 @boonebgorges
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for reporting back, @krioteh ! If you need more help debugging, I'd suggest checking out https://buddypress.org/support

Note: See TracTickets for help on using tickets.