Skip to:
Content

BuddyPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#8000 closed defect (bug) (fixed)

Border-radius set to naked/global "div".... why?

Reported by: capbell Owned by:
Milestone: Priority: high
Severity: major Version: 3.0.0
Component: Core Keywords:
Cc:

Description

Hi guys,

BP-Nouveau adds this styling:

div,
dl,
li,
textarea,
select,
input[type="search"],
input[type="submit"],
input[type="reset"] {
-webkit-border-radius: 2px;
-moz-border-radius: 2px;
-ms-border-radius: 2px;
border-radius: 2px;
background-clip: padding-box;
}

I am completely shocked and in disbelief how this got through to a major release. This css affects practically 95% of all elements (not just BuddyPress) on literally every normal-coded site in the world. Installing BuddyPress and using this template essentially means anything with borders/backgrounds/etc will look broken/silly.

Please fix and remove this. If you want to give something a border-radius, make it target the specific BuddyPress elements or a class.

Thanks.

Change History (2)

#1 @r-a-y
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed

Duplicate of #7940.

I'm marking the ticket as fixed, but it isn't. There's a bug on Trac that doesn't allow me to mark tickets as duplicates. Fixes will be included in #7940.

#2 @boonebgorges
2 years ago

In 12285:

Nouveau: border-radius declaration should be limited to #buddypress context.

The initial implementation was unbounded, affecting parts of a theme outside
of BuddyPress.

The change also includes some unrelated autoprefix changes due to running the
grunt sass task.

See #8000. Fixes #7940.

Note: See TracTickets for help on using tickets.