Skip to:
Content

BuddyPress.org

Opened 2 years ago

Closed 23 months ago

Last modified 23 months ago

#7969 closed defect (bug) (fixed)

Nouveau: Group members page doesn't load when both Activity and Notifications components are disabled

Reported by: r-a-y Owned by: r-a-y
Milestone: 3.3.0 Priority: normal
Severity: normal Version: 3.0.0
Component: Templates Keywords: has-patch commit
Cc:

Description

Reported here:
https://buddypress.org/support/topic/bug-membership-list-in-groups-does-not-show/

I've confirmed the problem. Both the Activity and Notifications components need to be disabled in order to duplicate the bug.

Attachments (2)

7969.01.patch (1.1 KB) - added by r-a-y 2 years ago.
7969.02.patch (825 bytes) - added by r-a-y 2 years ago.

Download all attachments as: .zip

Change History (6)

@r-a-y
2 years ago

#1 @r-a-y
2 years ago

  • Keywords has-patch added; needs-patch removed

01.patch fixes the problem by merging the needed group objects outside the foreach loop.

I tested this briefly and it appears to work. @imath, can you take a look at this to make sure this is the right approach?

Update - Just added 02.patch. I think this is cleaner.

Last edited 2 years ago by r-a-y (previous) (diff)

@r-a-y
2 years ago

#2 @imath
2 years ago

  • Keywords commit added

Thanks a lot @r-a-y for your work on the patches. I confirm it's fixing the issue and that the approach is safer, let's commit 02.patch.

#3 @r-a-y
23 months ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 12239:

Nouveau: Fix AJAX loading of group members page when the Activity and Notification components are disabled.

Problem was due to the way the required group objects were not being
initialized properly.

Props brianbws.

Fixes #7969 (3.x-branch)

#4 @r-a-y
23 months ago

In 12240:

Nouveau: Fix AJAX loading of group members page when the Activity and Notification components are disabled.

Problem was due to the way the required group objects were not being
initialized properly.

Props brianbws.

Fixes #7969 (trunk)

Note: See TracTickets for help on using tickets.