Skip to:
Content

BuddyPress.org

#7960 closed defect (bug) (fixed)

BP Nouveau: Errors when filtering the friends grid

Reported by: shubh14 Owned by: imath
Milestone: 3.2.0 Priority: normal
Severity: normal Version: 3.0.0
Component: Templates Keywords: has-patch commit
Cc:

Description

Query monitor plugin is showing me 2 php warnings that are triggered when I filter the friends list using the filter dropdown, however, the list does filter correctly. I have tested this in a fresh install to rule out any theme or plugin conflicts.

Indirect modification of overloaded property BP_Nouveau::$members_friends has no effect
Creating default object from empty value

Please see attached screenshot

Attachments (2)

bp-ajax.png (84.8 KB) - added by shubh14 15 months ago.
7960.patch (566 bytes) - added by imath 15 months ago.

Download all attachments as: .zip

Change History (10)

@shubh14
15 months ago

#1 @imath
15 months ago

  • Component changed from Core to Templates
  • Keywords has-patch reporter-feedback added
  • Version set to 3.0.0

Hi @shubh14

Thanks for your feedback, I don't manage to reproduce but I can imagine what's the reason of this trouble. You should have the same issue with group members if you also chose a multi columns layout.

Could you test the 7960.patch to see if it fixes the issue ?

@imath
15 months ago

#2 @shubh14
15 months ago

  • Keywords reporter-feedback removed

Hi, I tested the dropdown filtering for members directory, groups directory and single member's group list. There was no error. All the lists are multi-column.

The patch has worked. There are no errors when I filter a user's friend list.

Last edited 15 months ago by shubh14 (previous) (diff)

#3 @shubh14
15 months ago

Ok this is strange, it doesn't work when I edit the template-tags.php file in my child theme but it works when I change the file in the buddypress folder. Template hierarchy doesn't work here?

Doesn't work, still see errors

wp-content/themes/CHILDTHEME/buddypress/includes/template-tags.php

Works, no errors

wp-content/plugins/buddypress/bp-templates/bp-nouveau/includes/template-tags.php

#4 @imath
15 months ago

  • Keywords commit added
  • Milestone changed from Awaiting Review to 3.2.0

@shubh14

Thanks a lot for your feedback. Only what's in bp-templates/bp-nouveau/buddypress is overridable from a childtheme, so it's totally fine.

I'll commit the patch later today.

#5 @shubh14
15 months ago

Thank you for informing me about that.

Can you tell me when 3.2.0 would be released?

#6 @imath
15 months ago

As soon as we can.

#7 @imath
15 months ago

In 12212:

BP Nouveau: make sure to instantiate a friends & group members object

When displaying a multicolumn loop members for friends or group members, we need to instantiate a new object before adding properties to it.

Props shubh14

See #7960 (branch 3.0)

#8 @imath
15 months ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 12213:

BP Nouveau: make sure to instantiate a friends & group members object

When displaying a multicolumn loop members for friends or group members, we need to instantiate a new object before adding properties to it.

Props shubh14

Fixes #7960 (trunk)

Note: See TracTickets for help on using tickets.