Skip to:
Content

BuddyPress.org

Opened 18 months ago

Closed 15 months ago

Last modified 15 months ago

#7907 closed defect (bug) (fixed)

Activity comment notification not disappearing after click on it

Reported by: Diabolique Owned by: r-a-y
Milestone: 3.2.0 Priority: normal
Severity: normal Version: 2.6.0
Component: Activity Keywords: has-patch has-unit-tests
Cc:

Description

Usually notification is disappearing when you click on it, but there is 1 kind of notification which always remains after click on, it's an activity comment notification - https://imgur.com/a/71xjcj2

Attachments (3)

notification.gif (4.0 KB) - added by Diabolique 18 months ago.
Activity comment notification bug
7907.01.patch (2.1 KB) - added by r-a-y 17 months ago.
7907.02.patch (4.3 KB) - added by r-a-y 17 months ago.

Download all attachments as: .zip

Change History (10)

@Diabolique
18 months ago

Activity comment notification bug

#1 @DJPaul
18 months ago

I wonder if this is the same as #7849 -- @r-a-y ?

#2 @r-a-y
17 months ago

  • Component changed from Core to Activity
  • Keywords has-patch added; needs-patch removed
  • Milestone changed from Awaiting Review to 3.2.0
  • Owner set to r-a-y
  • Status changed from new to assigned
  • Version changed from 3.0.0 to 2.6.0

Looks like the notification mark-as-read code was missing for replies to activity updates and replies to activity comments 🙁

Attached patch should fix this.

I would like to move this to v3.2.0 even though this isn't a regression since this is an annoying bug, but feel free to move to v4.0.0.

Will try to write a unit test to cover this example as well.

@r-a-y
17 months ago

@r-a-y
17 months ago

#3 @r-a-y
17 months ago

  • Keywords has-unit-tests added

02.patch includes unit tests.

This ticket was mentioned in Slack in #buddypress by r-a-y. View the logs.


17 months ago

#5 @DJPaul
16 months ago

See also #7947

#6 @djpaul
15 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 12222:

Notifications: clear activity notifications for replies to updates and comments.

Fixes #7907

Props r-a-y

#7 @djpaul
15 months ago

In 12223:

Notifications: clear activity notifications for replies to updates and comments.

Fixes #7907 (3.0 branch)

Props r-a-y

Note: See TracTickets for help on using tickets.