Skip to:
Content

BuddyPress.org

Opened 16 months ago

Last modified 12 months ago

#7897 reopened defect (bug)

Nouveau - Can't post on Activity Directory page

Reported by: r-a-y Owned by: imath
Milestone: Awaiting Contributions Priority: normal
Severity: normal Version: 3.0.0
Component: Templates Keywords: needs-testing
Cc:

Description

Reported here:
https://buddypress.org/support/topic/cant-post-in-activity-stream/

User cannot post on the Activity Directory page (also doesn't load correctly), but can on their own profile's Activity page.

Screenshots:

http://smiling.wpengine.com/wp-content/uploads/2018/06/Screen-Shot-2018-06-07-at-2.28.06-PM.png
http://smiling.wpengine.com/wp-content/uploads/2018/06/Screen-Shot-2018-06-07-at-2.28.12-PM.png
http://smiling.wpengine.com/wp-content/uploads/2018/06/Screen-Shot-2018-06-07-at-2.28.21-PM.png

Attachments (1)

7897.patch (632 bytes) - added by imath 16 months ago.

Download all attachments as: .zip

Change History (12)

#1 @imath
16 months ago

  • Keywords reporter-feedback added

Hi r-a-y

It’s probably a JavaScript issue, can we have a screenshot of the user’s browser inspector ?

« Divi » is the name of the theme ?

How can we reproduce this ?

#2 @imath
16 months ago

Just tested in TwentySeventeen, and it works as expected.

https://cldup.com/Ji24rW01Jy.png

#3 @r-a-y
16 months ago

  • Keywords reporter-feedback removed

Here's another thread with similar problems with a screenshot of the browser log:
https://buddypress.org/support/topic/some-activity-stream-issues/

Screenshot:
http://dl3.joxi.net/drive/2018/06/06/0017/2626/1178178/78/0a3b06d22d.jpg

#4 @imath
16 months ago

  • Milestone changed from Awaiting Review to 3.2.0
  • Owner set to imath
  • Status changed from new to assigned

Thanks @r-a-y. It looks like it's a post-form.php template override. Problem is this template override is using a Legacy like markup. Nouveau is injecting Backbone views for the Post Form. I'll work on a patch to disable the JavaScript in this case.

@imath
16 months ago

#5 @imath
16 months ago

Well, no in case of a template override there's no problem actually 🤔

The patch is adding a check to be sure JS templates are available. Still a mystery...

#6 @DJPaul
15 months ago

Making sure that the templates we rely on are actually present is a good practice, and if it doesn't solve exactly this problem, it would be an improvement, as I'm sure it will fix edge cases.

We probably need to work on messaging around Nouveau that if you had customised Legacy templates, you're going to have problems.

#7 @r-a-y
14 months ago

  • Keywords needs-patch removed
  • Milestone changed from 3.2.0 to Awaiting Review

Moving back to Awaiting Review as we haven't been able to verify the report.

#8 @DJPaul
13 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

Closing due to lack of reporter feedback / verification in ~2 months.

#9 @r-a-y
12 months ago

  • Milestone set to Awaiting Review

Just marked #7968 as a duplicate. Going to reopen as this is an ongoing bug.

From all the reports, it appears to be an issue with WPEngine sites. Haven't figured out the cause yet.

Last edited 12 months ago by r-a-y (previous) (diff)

#10 @r-a-y
12 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

#11 @DJPaul
12 months ago

  • Milestone changed from Awaiting Review to Awaiting Contributions
Note: See TracTickets for help on using tickets.