Skip to:
Content

BuddyPress.org

#7868 closed defect (bug) (no action required)

activation letters leave the site but do not come to the user

Reported by: lasernur Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

all other letters come well
BuddyPress 3.0

WordPress 4.9.6

what is the problem?

Attachments (6)

2018-05-22 (8)_LI.jpg (644.3 KB) - added by lasernur 17 months ago.
2018-05-26 (2)_LI.jpg (729.9 KB) - added by lasernur 17 months ago.
2018-05-26 (3)_LI.jpg (1.3 MB) - added by lasernur 17 months ago.
2018-05-26 (4)_LI.jpg (1.1 MB) - added by lasernur 17 months ago.
2018-05-26 (5).png (337.7 KB) - added by lasernur 17 months ago.
2018-05-26 (7).png (321.7 KB) - added by lasernur 17 months ago.

Change History (15)

#1 @r-a-y
17 months ago

Thanks for the report.

Not sure how those activation emails are missing their situation.

Have you tried reinstalling the emails? You can do so in the admin dashboard and going to "Tools > BuddyPress" and selecting "Reinstall emails".

Last edited 17 months ago by r-a-y (previous) (diff)

#2 @lasernur
17 months ago

thanks for the answer. I do so, but the two activation letters are moved to the deleted ones. I publish them, and you can see it on the screen. but the problem remained

#3 @r-a-y
17 months ago

What happens when you try and edit the "Activate Your Account" email?

Do you see the situation -- "Recipient has registered for an account"? If so, select it and save.

https://i.imgur.com/miR2Pl4.png

#4 @lasernur
17 months ago

situation is not in the list!

#5 @r-a-y
17 months ago

Did you install BuddyPress 3.0 on a single-site install (not multisite)?

If so, try the following:

  1. Patch /bp-core/bp-core-functions.php as linked here - https://buddypress.trac.wordpress.org/attachment/ticket/7869/7869.01.patch
  2. In the admin dashboard, go to "Tools > BuddyPress" and re-run the "Reinstall emails" option.

Does that fix the problem?

Last edited 17 months ago by r-a-y (previous) (diff)

#6 @lasernur
17 months ago

made a patch, reinstalled the letters, but the activation letters remain in the trash

#7 @r-a-y
17 months ago

You need to remove all lines from 3391-3397 in the 2018-05-26 (5).png picture.

Once you've done that:

  1. Go to "Emails", click on "Trash" and click on the "Empty Trash" button.
  2. Go to "Tools > BuddyPress" and select "Reinstall emails"

Check to see if the activation email contains the email situation.

Last edited 17 months ago by r-a-y (previous) (diff)

#8 @lasernur
17 months ago

Wow cool !!!

#9 @r-a-y
17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Cool, looks like it is working.

Marking as a duplicate of #7869 as that is already reported.

Note: See TracTickets for help on using tickets.