Skip to:
Content

BuddyPress.org

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#7854 closed defect (bug) (fixed)

Group activity items not showing comment button for group members

Reported by: Venutius Owned by: r-a-y
Milestone: 3.1.0 Priority: normal
Severity: normal Version: 3.0.0
Component: Groups Keywords: has-patch
Cc:

Description

In the group activity page existing activity items are not displaying the comment icon for standard group members whilst it's displayed for site admin.

https://buddypress.org/support/topic/comment-button-and-reply-not-showing/

Attachments (1)

7854.01.patch (2.0 KB) - added by r-a-y 18 months ago.

Download all attachments as: .zip

Change History (5)

#1 @r-a-y
18 months ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.0.1
  • Summary changed from Nouveau - group activity items not showing comment button for group members to Group activity items not showing comment button for group members
  • Version set to 3.0.0

Confirmed. This isn't specific to Nouveau. This is due to a typo by me to address #4429 :(

01.patch should fix this. Includes a unit test.

@r-a-y
18 months ago

#2 @DJPaul
18 months ago

  • Milestone changed from 3.0.1 to 3.1.0

Milestone renamed

#3 @r-a-y
18 months ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 12131:

Groups: Fix display of "Comment" button in the activity stream.

In r11959, the banned group members check is using the wrong conditional.
This caused legitimate group members to never see the "Comment" button in
the activity stream.

This commit reverses the check and adds some unit tests (which should have
been written beforehand!).

Anti-props r-a-y.

See #4429.

Fixes #7854 (3.x branch).

#4 @r-a-y
18 months ago

In 12132:

Groups: Fix display of "Comment" button in the activity stream.

In r11959, the banned group members check is using the wrong conditional.
This caused legitimate group members to never see the "Comment" button in
the activity stream.

This commit reverses the check and adds some unit tests (which should have
been written beforehand!).

Anti-props r-a-y.

Fixes #7854 (trunk).

Note: See TracTickets for help on using tickets.