Skip to:
Content

BuddyPress.org

#7789 closed defect (bug) (fixed)

BP Nouveau: Activity filters in single group are failing

Reported by: imath Owned by: imath
Milestone: 3.0 Priority: normal
Severity: normal Version:
Component: Templates Keywords: has-patch dev-feedback
Cc:

Description

The problem is the data-bp-filter is set to an unexisting Ajax Action into bp_nouveau_current_object(). The data-bp-filter should be "activity" but it's "group_activity". It's not the case for the single use. A possible reason for this could be this function is also used to populate other filters.

https://cldup.com/U_ywfpEG8D.png

@hnla could you look at it ? Because you committed it :) https://github.com/buddypress/next-template-packs/commit/309ea3e1aeebfc63745f4d328613363864ae6933#diff-ce2d59a113459ec2d423b95e2a228d2e

What I suggest, is to simply add a specific case for the activity into this function while we figure out a bit more what the $component['data_filter'] is used for.

See attached patch.

Attachments (1)

7789.patch (838 bytes) - added by imath 14 months ago.

Download all attachments as: .zip

Change History (3)

@imath
14 months ago

This ticket was mentioned in Slack in #buddypress by imath. View the logs.


14 months ago

#2 @imath
14 months ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 12037:

BP Nouveau: use right Ajax action to filter single group activities

The Ajax action needs to be "activity_filter". JavaScript is building this argument using the "data-bp-filter" attribute of the activity type dropdown which needs to be set to "activity".

Fixes #7789

Note: See TracTickets for help on using tickets.