Skip to:
Content

Opened 8 weeks ago

Closed 7 weeks ago

#7784 closed defect (bug) (fixed)

Nouveau: Second row of group create steps spills over awkwardly

Reported by: boonebgorges Owned by: hnla
Milestone: 3.0 Priority: normal
Severity: normal Version:
Component: Templates Keywords: has-patch needs-testing
Cc:

Description

See screenshot.

It looks to me like this is being caused by the slightly increased height of the current item, which is causing the float flow to break.

Attachments (4)

Screenshot_2018-04-30_14-50-27.png (19.7 KB) - added by boonebgorges 8 weeks ago.
7784.diff (417 bytes) - added by boonebgorges 8 weeks ago.
Screenshot_2018-04-30_17-54-59.png (13.9 KB) - added by boonebgorges 8 weeks ago.
Screenshot_2018-04-30_17-56-50.png (13.6 KB) - added by boonebgorges 8 weeks ago.

Download all attachments as: .zip

Change History (10)

#1 @boonebgorges
8 weeks ago

I'm having a hard time forcing node-sass to run on my system, so I can't generate a proper patch. But it appears that the style in the attached patch will fix this specific issue. I'm unsure about unintended side-effects.

@boonebgorges
8 weeks ago

#2 @boonebgorges
8 weeks ago

  • Keywords has-patch needs-testing added

#3 @hnla
8 weeks ago

  • Owner set to hnla
  • Status changed from new to assigned

Impossible to stop, users have to take a view that if they want 200 menu items then they can't have tabs, there aren't always magic solutions - design conceits wrecks purity of web pages.

I might be able to tweak slightly, will take a look but not spending ages on it.

#4 @boonebgorges
8 weeks ago

I'm not suggesting they not spill over - I know you can't stop that. I'm saying that they should break cleanly into rows. At the moment, they can't do that because the current item is slightly taller than the ones without the current class. See Screenshot_2018-04-30_17-54-59.png for the "after" - note how item 7 is way over at the left instead of stuck just to the right of 'Settings'.

#5 @hnla
8 weeks ago

Ok got ya, will look at and frown a lot, I'll run the patch.

#6 @hnla
7 weeks ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 12061:

Nouveau: Adjust tabbed link styles

Commit addresses horizontal links when dropping to new line not able to float fully to the extreme edge past the current tabbed link due to neg margin.

Commit also addresses vert navs losing rulesets specificity on non floated lists due to recent grouped selector changes by adding in additional class.

Props boonebgorges hnla

Fixes #7784

Note: See TracTickets for help on using tickets.