Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

#7651 closed defect (bug) (no action required)

URGENT: Why can Only Admins Post and Subscribers cannot ?

Reported by: jasonb4u2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: (not sure) Keywords: close reporter-feedback
Cc:

Description

Only ADMINS can post, add friends ETC, why cant subscribers do anything, is there something Im missing here. Subscribers cant do anything, cant add friend, cant post etc, they can only view things.

Latest Wordpress, and built on Local Machine

They always receiving this message below:
Oops! You do not have sufficient permissions to access this page

<a href="http://prntscr.com/hvd62s" rel="noopener" target="_blank">http://prntscr.com/hvd62s</a>
http://prntscr.com/hvd62s

<a href="http://prntscr.com/hvd68j" rel="noopener" target="_blank">http://prntscr.com/hvd68j</a>
http://prntscr.com/hvd68j

Maybe a tweaking is needed somewhere ?

I cant even post anything in support forums, takes me to NOTHING FOUND response

This is kinda urgent. I didnt expect this to happen, was suppose to be easy

Change History (2)

#1 @boonebgorges
3 years ago

  • Keywords close reporter-feedback added; ui-feedback removed
  • Milestone changed from BuddyPress.org Sites to Awaiting Review
  • Priority changed from highest to normal
  • Severity changed from critical to normal

Sorry to hear you're having problems.

Oops! You do not have sufficient permissions to access this page

This is not a BuddyPress notice, nor is it from WordPress. Looking through the hundred or so plugins that I have installed on a local dev site, it appears that there's a number of other plugins that define this string. Look through your plugins to find out which it might be; I'd suggest something like: $ grep -nR 'do not have sufficient permissions to access' wp-content/plugins

By looking at the specific URL in the location bar, you might also be able to get a hint as to what plugin is at fault.

Please feel free to post your findings back here, but it's highly unlikely that this is issue is being caused by BP itself.

I cant even post anything in support forums, takes me to NOTHING FOUND response

This sounds like it's likely a separate issue, and may be a legitimate bug. If you can provide details to reproduce - the URL you visited, and the specifics of what you're seeing after you submit - we may be able to help diagnose.

#2 @DJPaul
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing because of no reporter feedback.

Note: See TracTickets for help on using tickets.