Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

#7644 closed defect (bug) (wontfix)

PHP Fatal error: Cannot redeclare class WP_Taxonomy

Reported by: mp518 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: Core Keywords: reporter-feedback
Cc:

Description

PHP Fatal error: Cannot redeclare class WP_Taxonomy in wp-content\plugins\buddypress\bp-forums\bbpress\bb-includes\backpress\class.wp-taxonomy.php on line 17

Change History (3)

#1 @DJPaul
3 years ago

  • Keywords reporter-feedback added
  • Milestone changed from Awaiting Review to Under Consideration

Hi @mp518

We've recently been looking at this issue. Can you confirm you have enabled the Legacy Forums (aka, bbPress 1) via the Components screen in BuddyPress?

Please also confirm which version of WordPress you are using.

I ask because I'm almost certain I know what the issue is -- https://buddypress.trac.wordpress.org/ticket/7502#comment:10 -- but these confirmations will let us be sure. Thank you.

#2 @mp518
3 years ago

Hi @DJPaul,

Yes, I have enabled the Legacy Forums via the components screen in BuddyPress.

Thank You.

#3 @DJPaul
3 years ago

  • Milestone Under Consideration deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thanks — read https://bpdevel.wordpress.com/2017/12/07/legacy-forums-support-will-be/

Long story short is these have been broken sometime. We are doing a small release this month to fix it, but with the subsequent major release (likely no earlier than late Feb), the Legacy Forums gesture is going to be removed.

If yours is a new site, we suggest just using the bbPress plugin rather than BuddyPress’ Legacy Forums feature.

Note: See TracTickets for help on using tickets.