Skip to:
Content

Opened 10 years ago

Closed 9 years ago

#754 closed defect (bug) (no action required)

Sitewide Activity doesn't show formatted text

Reported by: whitemonster Owned by:
Milestone: 1.2 Priority: minor
Severity: Version:
Component: Keywords: smiley support for widget
Cc:

Description

Well, I added the plugin "Tango Smileys Extended" which works awesome to add more smileys to my WPMU/BP installation... the problem is, when someone comments a puts a smiley in the comment/post (anything), when you go back to the MAIN PAGE the SITEWIDE ACTIVITY widget won't show the smiley. instead it'll show the ;nerd; or :P instead of the smiley itself... you can view this at: http://www.myhangoutonline.com if their is a fix, please let me know. thank you.

Change History (9)

#1 @ipstenu
10 years ago

This isn't a plugin issue, I have the same problem with the generic smilies, or any formatted text (bold etc). The smilies show up in RSS, though bold shows in neither.

#2 @ipstenu
10 years ago

  • Summary changed from Smileys in comments, etc... to Sitewide Activity doesn't show formatted text

Further inspection - There's no data being passed through to the sitewide output. The shows:

<blockquote>
</blockquote>

Stripping out everything if you have non-plain text, instead of just stripping the tags (I guess?).

#3 @ipstenu
10 years ago

This has now expanded with 1.0.3

I put bold, italics etc in my comments and the text shows up without that in the SiteWide activity. THAT alone would be fine, but it also strips out all smilies.

As far as I can sort out:
Sitewide Activity - Strip out images, unformats text
Group Forums - Strip out images, unformats text
Wire - Everything's fine!
bbPress - Everything's fine
Blog Posts and Comments - Everything's fine.

#4 @apeatling
10 years ago

  • Milestone set to 1.0.4

#5 @tedmann
10 years ago

Could this also explain why the ShareThis plugin's button is displayed as code --SHARETHIS.addEntry({ title: ””, url: ”” }); -- in the sitewide activity feed? This didn't seem to be a problem in the 1.0 release of BuddyPress, though I don't know if the filter was changed between then and 1.0.3

#6 @petronic
10 years ago

It would be great if in activity format functions there is a filter that can be used to create your own excerpt. Or at least that filters like xprofile_new_wire_post_activity have additional information, for example $wire_post.

#7 @apeatling
10 years ago

  • Milestone changed from 1.0.4 to 1.1

Milestone 1.0.4 deleted

#8 @apeatling
10 years ago

  • Milestone changed from 1.1 to 1.2

Filtering on activity streams will be sorted in 1.2, for now, and in the interest of making a quick change that might compromise security I'm leaving as is.

#9 @apeatling
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Some much has change with activity streams since this ticket, I'm marking it as invalid.

Note: See TracTickets for help on using tickets.