Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

#7539 closed defect (bug) (no action required)

buddypress extended profile fields don't work

Reported by: vcd2017 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Extended Profile Keywords:
Cc: visualcreativedesigns@…

Description

Hello,

I was checking out the buddypress xprofile field plugins a few types to do editing and customizing with for the extended profile section on my buddypress area. I know longer and do that, i can't even create a field name group or any field at all. Plus on my extended profile area under user i have this long line that says has been marked as a spammer. All BuddyPress data associated with the user has been removed on all my members i have on my site and yet the box above their photo shows it's active and not spammer so i am clueless on why this has happened.


Attachments (2)

buddypress-extended-profile fields.jpg (38.0 KB) - added by vcd2017 3 years ago.
profile fields
extended profile.jpg (77.8 KB) - added by vcd2017 3 years ago.
extended profile

Download all attachments as: .zip

Change History (7)

@vcd2017
3 years ago

profile fields

@vcd2017
3 years ago

extended profile

#1 @r-a-y
3 years ago

  • Keywords reporter-feedback needs-testing added
  • Priority changed from high to normal
  • Version 2.8.2 deleted

You have to determine what changed on your site between when the Extended Profile field functionality was last working and when the symptoms started.

We can only debug what we can duplicate, so if you are able to provide a list of steps to replicate the problem that will also help.

If you are using a bunch of 3rd-party BuddyPress plugins, try disabling them.

If you are using a caching plugin, try clearing the cache.

If you have a database backup of the last time your site was functioning proerply, try reverting to that.

#2 @vcd2017
3 years ago

i don't know. i just went in to disable it from the buddypress core that has extended profile option to than re enable it and it completely crashed my site trying to do that and i have no idea how i can go and enable it again anyway to do that from the database and what file to have that turned on, or in the buddypress location in the plugin folder?

#3 @r-a-y
3 years ago

Your problem might be related to #6685 in some way.

If you are able to and you have a backup, I would recommend reverting to a previous DB backup.

If you do not have a backup, try checking the wp_bp_xprofile_fields DB table.

See this comment in particular:
https://buddypress.trac.wordpress.org/ticket/6685#comment:2

#4 @vcd2017
3 years ago

i have fixed this. I deleted the database all together i found one from 3 hours ago, that didn't do anything, so than i deleted all buddypress plugins from the backend inside of the wordpress area and than re uploaded from the backend and refreshed the site and i was able to login and also it fixed the extended profile problem. no idea why this happened, was a pain in the butt and everything is back to working.

#5 @r-a-y
3 years ago

  • Keywords reporter-feedback needs-testing removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Oh, so the issue was a corrupt BuddyPress download?

Cool, glad it wasn't as serious as first mentioned! Going to close this one.

Note: See TracTickets for help on using tickets.