Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#7521 closed defect (bug) (duplicate)

xProfile fields meta data is not deleted when field is deleted

Reported by: slaFFik Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Extended Profile Keywords:
Cc:

Description

Example:
1) create a custom field (no matter in which fields group, even default one)
2) set its custom visibility, force visibility, required metas
3) check DB - records in wp_bp_xprofile_meta table are created for this new field
4) delete this field using standard BP functionality (on this page /wp-admin/users.php?page=bp-profile-setup click Delete for this new field)
5) check DB - field is deleted, metas - are not.

Same behavior when using directly built-in functions and methods, like BP_XProfile_Field::delete() etc.

Change History (2)

#1 @r-a-y
3 years ago

  • Milestone Awaiting Review deleted
  • Status changed from new to closed
  • Version 1.1 deleted

Duplicate of #6658.

#2 @r-a-y
3 years ago

  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.