Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#7518 closed defect (bug) (duplicate)

Profile field edit button in admin dashboard is linking to /wp-admin/network/users.php on multisite instead /wp-admin/users.php

Reported by: ecodemy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Wordpress: 4.7.4
Buddypress: 2.8.2

Problem is present with all other plugins deaktivated and with twenty sixteen theme enabled.

It is a WordPress multisite installation with subdirectories aktivated.

Buddpress is activated only on the main site, but not network wide. On the admin dashboard of the site (Users -> Profile Fields), the edit profile field button is linking to the network/users

e.g.:

/wp-admin/network/users.php?page=bp-profile-setup&group_id=1&field_id=1&mode=edit_field

resulting in a WordPress error "Sorry, you are not allowed to access this page."

But if you manually change the link to:

/wp-admin/users.php?page=bp-profile-setup&group_id=1&field_id=1&mode=edit_field

you can edit the the profile field as expected.

Change History (2)

#1 @r-a-y
3 years ago

  • Milestone Awaiting Review deleted
  • Status changed from new to closed
  • Version 2.8.2 deleted

Duplicate of #7472.

#2 @r-a-y
3 years ago

  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.