Skip to:
Content

BuddyPress.org

Opened 4 years ago

Closed 2 years ago

#7498 closed enhancement (no action required)

Activation with BP_SIGNUPS_SKIP_USER_CREATION = true and same email

Reported by: Maniou Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Registration Keywords:
Cc:

Description

Hello,

Maybe it will be nice to bring an enhancement in this context :

BP_SIGNUPS_SKIP_USER_CREATION = true

One user try to register with username = user_1 and mail = user_1@…
If just after he try to register with username = user_2 and mail = user_1@…

He's going to receveive 2 emails on the same adress email to validate the register process.

By clicking on one of the 2 activation link, the account is corectly validated.
If he click on the second activation link : there is a 404 blank page (even if the pending account is correctly deleted and the is no new user is created).

I think the best is to prevent to have 2 pending account with the same email on bp_core_validate_user_signup() :

The user can be confuse if he got 2 activation emails not knowing exactly wich username is going to be activated.

Thank you :)

Change History (2)

#1 @DJPaul
3 years ago

  • Component changed from Members to Registration
  • Milestone changed from Awaiting Review to Future Release

I haven't validated this in BP, but MS prevents this with the following message, we should, too:

That email address has already been used. Please check your inbox for an activation email. It will become available in a couple of days if you do nothing.

#2 @r-a-y
2 years ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to invalid
  • Status changed from new to closed

I believe this is a duplicate of #6895.

Note: See TracTickets for help on using tickets.